Closed Bug 1000047 Opened 6 years ago Closed 6 years ago

[tarako] Lockscreen has no response after call non-ecc number for several times

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

Other
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3 unaffected, b2g-v1.3T verified, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S1 (9may)
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- verified
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: angelc04, Assigned: etienne)

References

Details

(Whiteboard: [partner-blocker])

Attachments

(3 files)

Steps to reproduce
----------------------------------------------------------------------
1. Enable passcode lock and press power button to lock screen
2. Press power button to wake up device
3. On lockscreen, tap on Emergency Call
4. Dialer 100 ( or any non-ecc number) + call button. (repeat 2 ~ 3 times if not hitting hang issue)
   --> device will hang. But home button can recover this issue.
Attached image screenshot.png
The screen looks like this after this issue happens and resume from it. Homescreen or any other app UI was shift a little to the bottom. pls see attached screenshot.
I don't seem to be hitting this issue for buri.
blocking-b2g: --- → 1.3T?
Hi Peipei, does the emergency call work in the emergency call screen?
Flags: needinfo?(pcheng)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #3)
> Hi Peipei, does the emergency call work in the emergency call screen?

Yes. Emergency call (such as 112 and 911) works. This issue only happens when dial non-ecc number for several times.
Flags: needinfo?(pcheng)
Hi Etienne, could you help to check this issue? thanks!
Flags: needinfo?(etienne)
I can reproduce the issue, taking.
Assignee: nobody → etienne
Flags: needinfo?(etienne)
Attached file Gaia PR
This was a tricky one...
Attachment #8412755 - Flags: review?(anthony)
Triage. 1.3T+
blocking-b2g: 1.3T? → 1.3T+
Status: NEW → ASSIGNED
Component: Gaia::System::Lockscreen → Gaia::Dialer
Whiteboard: [partner-blocker]
Comment on attachment 8412755 [details] [review]
Gaia PR

Nothing to say, good job.
Attachment #8412755 - Flags: review?(anthony) → review+
Hi! James,

Check in needed. Thanks.

--
Keven
Flags: needinfo?(james.zhang)
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/commit/d9cb98243113558e4581c6bfcb6515ae6b088620
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Yang, please land this patch on v1.3t.
Flags: needinfo?(james.zhang) → needinfo?(yang.zhao)
What about v1.4?
status-b2g-v1.4: --- → ?
Flags: needinfo?(etienne)
Keywords: checkin-needed
Target Milestone: --- → 2.0 S1 (9may)
(In reply to James Zhang from comment #12)
> Yang, please land this patch on v1.3t.

See comment # 14,Michael already landed it.
Flags: needinfo?(yang.zhao)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #13)
> What about v1.4?

Yes we need it too.
Flags: needinfo?(etienne)
(In reply to Etienne Segonzac (:etienne) from comment #16)
> (In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #13)
> > What about v1.4?
> 
> Yes we need it too.

scratch that, sorry.
The dedicated callscreen app is not part of 1.4.
Putting the dependency in case bug 990003 get's uplifted to 1.4.
Blocks: 990003
Verified fixed on the Tarako v1.3T MOZ ril.

Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140602014001
Gaia: 335486c42498fa7a93c21e4d6121199728602ab8
Gecko: 55e4d83019e5
Version: 28.1
Firmware Version: SP6821a-Gonk-4.0-4-29

Regular call will not call out in emergency mode, takes user back to the lock screen.
Hi etienne:

There is a bug on v1.4 which I checked is caused by the pull request 21282 you merged in 7.4. 

The testing steps of this bug is:
a) Power ON 7715 with operators in respective slot.
b) Make MTC on Sim 1 and receive the call.
c) Use data services.(as Facebook, Youtube etc..)
d) 7715 shows improper link blink on the green label while using data in call.

And the testing result is:
7715 shows improper link blink on the green label while using data in call.

Can you help me to check this bug and find which modification caused this issue?

Thank you.
Flags: needinfo?(etienne)
Hi etienne:

This is the video of this issue in the attachment. It is not quite clear,but we can see the improper link blink on the green label. 

Thank you.
(In reply to jinghua.xing from comment #22)
> Created attachment 8471343 [details]
> The video of showing  improper link blink on the green label
> 
> Hi etienne:
> 
> This is the video of this issue in the attachment. It is not quite clear,but
> we can see the improper link blink on the green label. 
> 
> Thank you.

I'm not seeing anything unexpected on this video... so not sure what to do.
But if it's not related to this bug specifically we should probably move the discussion to a separated bug.
Flags: needinfo?(etienne)
You need to log in before you can comment on or make changes to this bug.