Closed Bug 1000062 Opened 6 years ago Closed 6 years ago

Delete some more redundant tests

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: zcampbell, Assigned: Bebe)

Details

Attachments

(1 file, 3 obsolete files)

The following tests either have v good coverage in the javascript tests, or are not likely to test device hardware specifically and hence are low value to us.

Thus it's safe to delete them and we can save some runtime.

test_clock_delete_alarm
test_clock_switch_clock_type
test_everythingme_launch_packaged_app
test_gallery_share_menu
test_settings_do_not_track
test_settings_app_permissions
Should we removed the associated unused app object methods?
Yes Bebe, remove app objects, but not anything in gaia_test.py or atoms.
Assignee: nobody → florin.strugariu
Attached file Delete clock tests (obsolete) —
Attachment #8411004 - Flags: review?(zcampbell)
Attachment #8411004 - Flags: review?(viorela.ioia)
Attachment #8411039 - Flags: review?(zcampbell)
Attachment #8411039 - Flags: review?(viorela.ioia)
Comment on attachment 8411004 [details] [review]
Delete clock tests

See comments in the PR
Attachment #8411004 - Flags: review?(viorela.ioia) → review-
Attachment #8411004 - Flags: review- → review?(viorela.ioia)
I updated both pulls
Comment on attachment 8411039 [details]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/18592/files

r+ from me
Attachment #8411039 - Flags: review?(zcampbell) → review+
Attachment #8411039 - Flags: review?(viorela.ioia) → review+
Comment on attachment 8411004 [details] [review]
Delete clock tests

r+
Attachment #8411004 - Flags: review?(zcampbell) → review+
Some comments/questions on the tests being removed below.

(In reply to Zac C (:zac) from comment #0)
> test_clock_delete_alarm
> test_clock_switch_clock_type

I know Marcus covered these tests in Marionette JS. The only concern I have is the fact that those tests are running in process, not out of process. I thought the original plan was that we were going to leave these tests in until the Marionette JS tests could be ran out of process.

> test_everythingme_launch_packaged_app

Is this mostly covered by what test_everythingme_launch_app.py covers?

> test_gallery_share_menu

Why is this specifically being removed?

> test_settings_do_not_track

I think this has regressed before. Is there equivalent Marionette JS coverage for this?

> test_settings_app_permissions

Note - we've had regressions with this in the past. Do we have equivalent JS integration coverage here?
Jason,
the two clock tests, test_me_launch_package_appm test_settings_do_not_track, test_settings_app_permissions are all dupes of Marionette JS tests. We still have two other clock tests that run OOP and other settings/e.me coverage that marionette JS and desktopb2g cannot reach.

test_gallery_share_menu, this test just doesn't really do anything. Regressions here we've

Just to put these deletions in context, we are still taking on other smoketests and just merged the receive_call test, I think that's more important coverage.
Attachment #8411004 - Flags: review?(viorela.ioia) → review+
Attachment #8411004 - Attachment is obsolete: true
Attachment #8411039 - Attachment is obsolete: true
Comment on attachment 8412608 [details] [review]
test_gallery_share  Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/18686

r+
Attachment #8412608 - Flags: review?(zcampbell) → review+
Comment on attachment 8412634 [details]
Settings Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/18687#attch-to-bugzilla

r-, remove 1 locator too.
Attachment #8412634 - Flags: review?(zcampbell) → review-
(In reply to Zac C (:zac) from comment #11)
> Jason,
> the two clock tests, test_me_launch_package_appm test_settings_do_not_track,
> test_settings_app_permissions are all dupes of Marionette JS tests. We still
> have two other clock tests that run OOP and other settings/e.me coverage
> that marionette JS and desktopb2g cannot reach.
> 
> test_gallery_share_menu, this test just doesn't really do anything.
> Regressions here we've
> 
> Just to put these deletions in context, we are still taking on other
> smoketests and just merged the receive_call test, I think that's more
> important coverage.

Ok - that sounds fine.
Tony, cc:ing and need-info'ing you to keep you in the loop on why/what we're doing, here.
Flags: needinfo?(tchung)
We've decided not to remove test_settings_do_not_track as our Python test is slightly better than the js one. but a small improvement on the js side means we could delete it.
Attachment #8412608 - Attachment is obsolete: true
Attachment #8412634 - Flags: review- → review?(zcampbell)
Comment on attachment 8412634 [details]
Settings Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/18687#attch-to-bugzilla

Travis green, r+!
Attachment #8412634 - Flags: review?(zcampbell) → review+
Merged remove of test_app_permissions:
https://github.com/mozilla-b2g/gaia/commit/2ddaaa230ca53ec0d911f5778b473a89be8c3c3b

All tasks are done from this bug.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
(In reply to Stephen Donner [:stephend] from comment #19)
> Tony, cc:ing and need-info'ing you to keep you in the loop on why/what we're
> doing, here.

thanks for the heads up!  i agree with redundant tests.   please keep up the cleanup.
Flags: needinfo?(tchung)
You need to log in before you can comment on or make changes to this bug.