Editor content context menu shouldn't collapse its menuitems

VERIFIED FIXED in mozilla0.9.5

Status

SeaMonkey
Composer
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: Charles Manske)

Tracking

({polish})

Trunk
mozilla0.9.5
polish

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Using Build ID: 2001091403
Steps to reproduce problem:
1. Open a new composer window
2. Open the content context menu

Actual results: Context menu has blank gap at the bottom.

Expected results: Unwanted menuitems should be completely undetectable.

Additional information: Try repeatedly pressing down arrow.
(Reporter)

Comment 1

16 years ago
Created attachment 49569 [details] [diff] [review]
Proposed patch
(Reporter)

Updated

16 years ago
Keywords: patch, polish, review, ui

Comment 2

16 years ago
-->cmanske
r=brade
Assignee: syd → cmanske
OS: Windows 95 → All
Hardware: PC → All
Target Milestone: --- → mozilla0.9.5
(Reporter)

Comment 3

16 years ago
CCing kin@netscape.com for sr
(Assignee)

Comment 4

16 years ago
Wait! I already have these changes plus other tweaks to the context menu in my
tree. This is actually a dup of another bug.
(Assignee)

Comment 5

16 years ago
Created attachment 50292 [details] [diff] [review]
My version of the fix, with minor differences to cleanup context menu code
(Assignee)

Comment 6

16 years ago
I can't find the original bug on this issue -- it was sent to XPFE group.
The menu widget arrow navigation should skip over both "collapsed" and 
"hidden" items; the issue was seen only in Composer 'cause we used 'collapsed'
while other modules used 'hidden'. So I didn't check in my fix so they would have
a test case. But at this point, I agree we should probably just checkin a fix
for Composer so the menu works right even if other bug isn't fixed.
As you can see, my patch does everything Neil's does, plus some other cleanup,
such as consistent use of " instead of '.
Neil or Kathy: Could you please r= my fix?
Status: NEW → ASSIGNED
Whiteboard: FIX IN HAND need SR

Comment 7

16 years ago
sr=hewitt
(Assignee)

Updated

16 years ago
Attachment #50292 - Flags: superreview+
(Assignee)

Updated

16 years ago
Attachment #49569 - Flags: review+
(Assignee)

Comment 8

16 years ago
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Whiteboard: FIX IN HAND need SR

Comment 9

16 years ago
Neil, can you verofy this on the latest build and mark
VERIFIED? thanks.
(Assignee)

Comment 10

16 years ago
Sujay: You can verify: Open a popup menu and use down arrow key -- each keypress
should go to the next item. That was the original issue that caused these changes.
But since I just did that, I guess I can mark it verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.