Closed Bug 1000214 Opened 6 years ago Closed 6 years ago

Progress bar didn't update when display is suspended and audio is paused after a while

Categories

(Firefox OS Graveyard :: Gaia::Music, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S1 (9may)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: vasanth, Assigned: squib)

References

()

Details

(Whiteboard: [CR 648933])

Attachments

(1 file)

46 bytes, text/x-github-pull-request
dkuo
: review+
Details | Review
STR
---
1. Connect headset.
2. Play clip for few seconds example 5 seconds.
3. Suspend Display using power key (playback continues in background). 
4. Unplug headset after few seconds example after 20 seconds (playback pauses).
5. Resume back the display using power key and check the time of Progress bar.

Actual: Progress bar time is showing as 5 seconds in paused state
Expected: Progress bar time should show as 25 seconds (5+20)

After step #3, timeupdate listener is removed since UI is invisible [1]. Even when UI is invisible, I guess we should try to update seekbar during playstate changes.

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/music/js/Player.js#L40
Probably a regression.

Adding qawanted here to check behavior on 1.3.
Keywords: qawanted
Hema

Please check for Music.
blocking-b2g: 1.4? → 1.4+
Flags: needinfo?(hkoka)
(In reply to vasanth from comment #0)
> STR
> ---
> 1. Connect headset.
> 2. Play clip for few seconds example 5 seconds.
> 3. Suspend Display using power key (playback continues in background). 
> 4. Unplug headset after few seconds example after 20 seconds (playback
> pauses).
> 5. Resume back the display using power key and check the time of Progress
> bar.
> 
> Actual: Progress bar time is showing as 5 seconds in paused state
> Expected: Progress bar time should show as 25 seconds (5+20)
> 
> After step #3, timeupdate listener is removed since UI is invisible [1].
> Even when UI is invisible, I guess we should try to update seekbar during
> playstate changes.
> 
> [1]
> https://github.com/mozilla-b2g/gaia/blob/master/apps/music/js/Player.js#L40

1) DUT is it KK?
2) Please help with regression window
Whiteboard: [CR 648633] → [CR 648933]
(In reply to Preeti Raghunath(:Preeti) from comment #3)
> 1) DUT is it KK?
> 2) Please help with regression window

Yes. However I guess this issue would be there in V1.3 as well.
Taking.
Assignee: nobody → squibblyflabbetydoo
Status: NEW → ASSIGNED
(In reply to Jason Smith [:jsmith] from comment #1)
> Probably a regression.
> 
> Adding qawanted here to check behavior on 1.3.

This issue is present in today's 1.3. Music player's progress bar does not update upon screen on, if headset is unplugged and music is paused while screen is off.

Tested on:
Device: Buri 1.3 MOZ
BuildID: 20140423024002
Gaia: fb2b8e25e8095a5db49b5eb68c74b49f180605d4
Gecko: da2500909f91
Version: 28.0
Firmware Version: v1.2-device.cfg
Keywords: qawanted
Attached file Fix it
This fixes it. I'm still thinking about how to test this, since it seems to require hardware to reproduce.
Flags: needinfo?(hkoka)
Comment on attachment 8411197 [details] [review]
Fix it

Ok, I added some tests, and confirmed that they fail before the fix and pass after it.
Attachment #8411197 - Flags: review?(dkuo)
Comment on attachment 8411197 [details] [review]
Fix it

Jim, the patch and tests looks good to me, there is one minor thing I think probably could also do it in this patch, please see the github comments, and thanks for working on it! (I remember there is one dupe and I will dupe it after you land this)
Attachment #8411197 - Flags: review?(dkuo) → review+
Landed on master (with the suggested changes):

  https://github.com/mozilla-b2g/gaia/commit/7d7de8f2f6775994d334edbc4bcb5d9681db7938
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Duplicate of this bug: 874288
A new test case is required for this to be covered.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Flags: in-moztrap?(srapanan)
Test case has been added to moztrap:

https://moztrap.mozilla.org/manage/case/14374/
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: in-moztrap?(srapanan)
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.