parent.framename.history.go(-1) work with global history, not with history of target frame :(

VERIFIED WORKSFORME

Status

()

Core
Document Navigation
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: slava, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4+) Gecko/20010914
BuildID:    2001091412

At multiframes page, where one of frame use tag 
<META HTTP-EQUIV= "Refresh" Content="15">
(autoreloading frequency), window.history.go(-1) or
onClick='parent.panelmain.history.go(-1)' turn back at first the frame,
whitch was updated. This command may be executed such numbers, as frequency
updated frame was changed, and only after this, it make go.(-1) for target
frame. Its similar, that parent.framename.history.go(-1) work with global
history, not with history of target frame. In mozilla 0.93 this work whell. Bug
are reanimation in 0.94 :(

Reproducible: Always
Steps to Reproduce:
1.Open any frameset, where one of frame are autorefreshed 
2.Wait for some autorefresh
3.Try to make parent.framename.history.go(-1) in the static frame. 

Actual Results:  As result, we go back in autorefreshed frame. We need click as
many time, as was autorefreshed in another frame, before we can go back in the
target frame

All this work without problem in Mozilla 0.93 and in IE. Now i can not write
adress of URL to demonstration, because its problem i see at our internal
system. If need, i make demonstration page some days later...
This problem i was tested in 0.94 "release" build and in last "nightly".
(Reporter)

Comment 1

17 years ago
Build 2001092518 now is don't have this bug. Possibly fixed and was depend of
other bug...

Comment 2

17 years ago
resolving per reporter's comment
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs which haven't changed since 2001.12.31.

set your search string in mail to "EmperorLondoMollari" to filter out these
messages.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.