[B2G][Lockscreen] Tapping the home button on the lockscreen immediatley promts passcode

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: dharris, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.3 affected, b2g-v1.3T affected)

Details

(Whiteboard: [tarako-exploratory], )

Attachments

(1 attachment)

Posted file Logcat, Firewatch
Description:
When the user requires a passcode to show up on the lockscreen after any amount of time, the user can tap on the home button while looking at the lockscreen and the the passcode will show up immediatley.

Prerequisites: Have a passcode set, Rquire the passcode after 4 hours

Repro Steps:
1) Update a Tarako to BuildID: 20140423014003
2) Press the lockscreen button on top of the phone
3) Press lockscreen button again to see lockscreen
4) Tap the home button on the bottom of the phone

Actual:
The phone prompts the user to enter a passcode

Expected:
The home button has no effect when on the lockscreen 

1.3t Environmental Variables:
Device: Tarako 1.3t
BuildID: 20140423014003
Gaia: 9aa9b04049f0291b124c50e0f9c3ce0e1f547725
Gecko: 5dc3e5ec4178
Version: 28.1
Firmware Version: sp6821


Keywords: Unlock, Shown, Bypass, Requirement


Notes: When prompting the passcode this way, the user is able to press cancel and then unlock the phone without typing in a passcode


Repro frequency: 100%
See attached: Firewatch, Logcat, Video - https://www.youtube.com/watch?edit=vd&v=lFlTawWhvcY
Above issue also occurs in Buri 1.3

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140422024003
Gaia: cab7de82832d00696807ae48ec277bd642b82a0a
Gecko: c35695cc384c
Version: 28.0
Firmware Version: v1.2-device.cfg
I'm not sure if this is a bug. I think it might be by design...
Flags: needinfo?(firefoxos-ux-bugzilla)
Flagging Jacqueline on this, which appears to be a bug.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(jsavory)
Yes, this is definitely a bug since users can bypass the lockscreen. 
The expected result is correct, the home button should have no effect on the lockscreen. If the user does swipe to see the passcode, cancel should return to the lockscreen.
Flags: needinfo?(jsavory)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.