Closed Bug 1000643 Opened 8 years ago Closed 6 years ago

Intermittent testClearPrivateData | Exception caught - junit.framework.AssertionFailedError: Text string: 'Clear data' is not found!

Categories

(Firefox for Android Graveyard :: General, defect)

All
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1216257

People

(Reporter: KWierso, Assigned: gbrown)

Details

(Keywords: intermittent-failure)

https://tbpl.mozilla.org/php/getParsedLog.php?id=38354714&tree=B2g-Inbound
Android 2.2 Armv6 Tegra b2g-inbound opt test robocop-1 on 2014-04-23 15:57:25 PDT for push 190a19291d8c

slave: tegra-239



20 INFO TEST-PASS | testClearPrivateData | Verify that the option: Share is in the list - The option is in the list. There are settings to clear
21 INFO TEST-PASS | testClearPrivateData | Waiting for the pop-up to open - Pop up was opened
22 INFO TEST-PASS | testClearPrivateData | Verify that the option: There are no settings to clear is in the list - The option is in the list. There are settings to clear
23 INFO TEST-PASS | testClearPrivateData | waiting for urlbar text to gain focus - urlbar text gained focus
24 INFO TEST-PASS | testClearPrivateData | URL typed properly - http://mochi.test:8888/tests/robocop/robocop_geolocation.html should equal http://mochi.test:8888/tests/robocop/robocop_geolocation.html
25 INFO TEST-PASS | testClearPrivateData | Given message occurred for registered event: {"errorType":"","bgColor":"transparent","type":"DOMContentLoaded","tabID":0} - DOMContentLoaded should equal DOMContentLoaded
EventExpecter: no longer listening for DOMContentLoaded
26 INFO TEST-PASS | testClearPrivateData | Doorhanger:Share your location with has been displayed - true should equal true
27 INFO TEST-PASS | testClearPrivateData | Doorhanger:Share your location with has been hidden - false should equal false
28 INFO TEST-PASS | testClearPrivateData | Waiting for the pop-up to open - Pop up was opened
29 INFO TEST-PASS | testClearPrivateData | Verify that the option: Don't share is in the list - The option is in the list. There are settings to clear
waitForText timeout on ^Settings$
Exception caught during test!
junit.framework.AssertionFailedError: Text string: 'Clear data' is not found!
	at junit.framework.Assert.fail(Assert.java:47)
	at junit.framework.Assert.assertTrue(Assert.java:20)
	at com.jayway.android.robotium.solo.Clicker.clickOnText(Clicker.java:383)
	at com.jayway.android.robotium.solo.Solo.clickOnText(Solo.java:1028)
	at org.mozilla.gecko.tests.BaseTest.clearPrivateData(BaseTest.java:660)
	at org.mozilla.gecko.tests.testClearPrivateData.clearPrivateData(testClearPrivateData.java:16)
	at org.mozilla.gecko.tests.testClearPrivateData.checkDevice(testClearPrivateData.java:82)
	at org.mozilla.gecko.tests.testClearPrivateData.clearSiteSettings(testClearPrivateData.java:67)
	at org.mozilla.gecko.tests.testClearPrivateData.testClearPrivateData(testClearPrivateData.java:22)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:521)
	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:204)
	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:194)
	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:186)
	at org.mozilla.gecko.tests.BaseTest.runTest(BaseTest.java:125)
	at junit.framework.TestCase.runBare(TestCase.java:127)
	at junit.framework.TestResult$1.protect(TestResult.java:106)
	at junit.framework.TestResult.runProtected(TestResult.java:124)
	at junit.framework.TestResult.run(TestResult.java:109)
	at junit.framework.TestCase.run(TestCase.java:118)
	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:169)
	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:154)
	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:520)
	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1447)
30 INFO TEST-UNEXPECTED-FAIL | testClearPrivateData | Exception caught - junit.framework.AssertionFailedError: Text string: 'Clear data' is not found!
31 INFO TEST-END | testClearPrivateData | finished in 142700ms
32 INFO TEST-START | Shutdown
testClearPrivateData fails the same way on Android 4.3.

http://ftp.mozilla.org/pub/mozilla.org/mobile/try-builds/gbrown@mozilla.com-e80c0fdd1ef6/try-android-api-9/try_ubuntu64_vm_mobile_test-robocop-1-bm114-tests1-linux64-build7.txt.gz

18:07:27     INFO -  TEST-START | testClearPrivateData
18:07:27     INFO -  TEST-PASS | testClearPrivateData | Robocop tests need the test device screen to be powered on. - 
18:07:27     INFO -  TEST-PASS | testClearPrivateData | Given message occurred for registered event: {"type":"Gecko:Ready"} - Gecko:Ready should equal Gecko:Ready
18:07:27     INFO -  EventExpecter: no longer listening for Gecko:Ready
18:07:27     INFO -  TEST-PASS | testClearPrivateData | waiting for urlbar text to gain focus - urlbar text gained focus
18:07:27     INFO -  TEST-PASS | testClearPrivateData | URL typed properly - http://mochi.test:8888/tests/robocop/robocop_blank_01.html should equal http://mochi.test:8888/tests/robocop/robocop_blank_01.html
18:07:27     INFO -  TEST-PASS | testClearPrivateData | Given message occurred for registered event: {"errorType":"","bgColor":"transparent","type":"DOMContentLoaded","tabID":0} - DOMContentLoaded should equal DOMContentLoaded
18:07:27     INFO -  EventExpecter: no longer listening for DOMContentLoaded
18:07:27     INFO -  TEST-PASS | testClearPrivateData | The url argument is not null - http://mochi.test:8888/tests/robocop/robocop_blank_01.html should not equal null
18:07:27     INFO -  TEST-PASS | testClearPrivateData | Page title is correct - mochi.test:8888/tests/robocop/robocop_blank_01.html should equal mochi.test:8888/tests/robocop/robocop_blank_01.html
18:07:27     INFO -  TEST-PASS | testClearPrivateData | Inserting/updating a new bookmark - Inserting/updating the bookmark with the title = Browser Blank Page 02 and the url = http://mochi.test:8888/tests/robocop/robocop_blank_02.html
18:07:27     INFO -  TEST-PASS | testClearPrivateData | Checking that the number of history items is correct - 1 history items present in the database
18:07:27     INFO -  TEST-PASS | testClearPrivateData | Waiting for and scrolling once to find item ^Privacy$ - ^Privacy$ found
18:07:27     INFO -  TEST-PASS | testClearPrivateData | Waiting for enabled text ^Privacy$ - ^Privacy$ option is present and enabled
18:07:27     INFO -  TEST-PASS | testClearPrivateData | Waiting for and scrolling once to find item ^Clear now$ - ^Clear now$ found
18:07:27     INFO -  TEST-PASS | testClearPrivateData | Waiting for enabled text ^Clear now$ - ^Clear now$ option is present and enabled
18:07:27     INFO -  5 ERROR Exception caught during test! - junit.framework.AssertionFailedError: Text string: 'Clear data' is not found!
18:07:27     INFO -  	at junit.framework.Assert.fail(Assert.java:50)
18:07:27     INFO -  	at junit.framework.Assert.assertTrue(Assert.java:20)
18:07:27     INFO -  	at com.jayway.android.robotium.solo.Clicker.clickOnText(Clicker.java:383)
18:07:27     INFO -  	at com.jayway.android.robotium.solo.Solo.clickOnText(Solo.java:1028)
18:07:27     INFO -  	at org.mozilla.gecko.tests.BaseTest.clearPrivateData(BaseTest.java:754)
18:07:27     INFO -  	at org.mozilla.gecko.tests.testClearPrivateData.clearPrivateData(testClearPrivateData.java:23)
18:07:27     INFO -  	at org.mozilla.gecko.tests.testClearPrivateData.checkDevice(testClearPrivateData.java:93)
18:07:27     INFO -  	at org.mozilla.gecko.tests.testClearPrivateData.clearHistory(testClearPrivateData.java:48)
18:07:27     INFO -  	at org.mozilla.gecko.tests.testClearPrivateData.testClearPrivateData(testClearPrivateData.java:28)
18:07:27     INFO -  	at java.lang.reflect.Method.invokeNative(Native Method)
18:07:27     INFO -  	at java.lang.reflect.Method.invoke(Method.java:525)
18:07:27     INFO -  	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:214)
18:07:27     INFO -  	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:199)
18:07:27     INFO -  	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:192)
18:07:27     INFO -  	at org.mozilla.gecko.tests.BaseTest.runTest(BaseTest.java:132)
18:07:27     INFO -  	at junit.framework.TestCase.runBare(TestCase.java:134)
18:07:27     INFO -  	at junit.framework.TestResult$1.protect(TestResult.java:115)
18:07:27     INFO -  	at junit.framework.TestResult.runProtected(TestResult.java:133)
18:07:27     INFO -  	at junit.framework.TestResult.run(TestResult.java:118)
18:07:27     INFO -  	at junit.framework.TestCase.run(TestCase.java:124)
18:07:27     INFO -  	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:191)
18:07:27     INFO -  	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:176)
18:07:27     INFO -  	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:554)
18:07:27     INFO -  	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1701)
18:07:27     INFO -  
18:07:27  WARNING -  TEST-UNEXPECTED-FAIL | testClearPrivateData | Exception caught - junit.framework.AssertionFailedError: Text string: 'Clear data' is not found!
18:07:27     INFO -  TEST-OK | testClearPrivateData | took 125433ms
18:07:27     INFO -  TEST-START | Shutdown
18:07:27     INFO -  Passed: 13
18:07:27     INFO -  Failed: 1
Whiteboard: [test disabled on android 4.3]
This test has been deleted.
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Whiteboard: [test disabled on android 4.3]
Duplicate of bug: 1216257
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.