multi-line combo boxes are not redrawn properly after using the scroll bar

RESOLVED DUPLICATE of bug 95703

Status

--
minor
RESOLVED DUPLICATE of bug 95703
17 years ago
10 years ago

People

(Reporter: cpeel, Assigned: kmcclusk)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091303

When using the scroll bar on a page with a multi-line combo box (like the CC
combo box on a bugzilla bug page) the empty area of the box is not redrawn with
the normal solid color, but rather is being redrawn with what appears to be
areas from other parts of the window.

Reproducible: Always
Steps to Reproduce:
1. Open bug 98830 (a the time of this writing, there is only one person in the
CC list. Should more people be added to the list and the CC box become full,
this example will become invalid).
2. Using the scroll bar, scroll down the page until the CC box is completely off
the window.
3. Scroll back up until the CC box is on the window.


Actual Results:  The empty lines of the CC box is filled in with an area from
(what looks like) another part of the window.

Expected Results:  Redrawn the entire CC box with the standard form-input
background color (which on Windows is the system "window" color).
(Reporter)

Comment 1

17 years ago
Created attachment 49584 [details]
Screenshot of the bug in action. Notice the CC combo box specifically.

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 95703 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.