Fullscreen button no longer shows the depressed state in the menu panel when in fullscreen

VERIFIED FIXED in Firefox 30

Status

()

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: MattN, Assigned: mikedeboer)

Tracking

(Blocks 1 bug, {regression})

29 Branch
Firefox 31
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox29 wontfix, firefox30 fixed, firefox31 verified, b2g-v1.4 fixed)

Details

(Whiteboard: [Australis:P4-])

Attachments

(2 attachments)

This worked some months ago with Australis so it seems like this regressed. It seems like the more specific rules are preventing the change from appearing. The button shows the proper state in toolbars.

This seems to affect at least Windows and OS X.
Assignee

Comment 1

5 years ago
This was regressed by bug 979378.

Taking & fixing this.
Blocks: 979378
Assignee

Updated

5 years ago
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Comment on attachment 8411644 [details] [diff] [review]
Patch v1: re-introduce a checked state for panel-menu buttons

Review of attachment 8411644 [details] [diff] [review]:
-----------------------------------------------------------------

Don't forget to update the reviewer.

Thanks for jumping on this so quickly and please request uplift.

::: browser/themes/shared/customizableui/panelUIOverlay.inc.css
@@ +727,5 @@
>  .toolbaritem-combined-buttons@inAnyPanel@@buttonStateHover@ {
>    border-color: hsla(210,4%,10%,.11);
>  }
>  
> +panelview .toolbarbutton-1:-moz-any(@buttonStateActive@,[checked=true]),

OK, my understanding is that it's fine to use this as the right-most selector here for perf.[1] since it's attached to the toolbarbutton-1 class.

[1] https://developer.mozilla.org/en-US/docs/Web/CSS/:any#Issues_with_performance_and_specificity
Attachment #8411644 - Flags: review?(MattN+bmo) → review+
https://hg.mozilla.org/mozilla-central/rev/0bfe1f94e874
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Assignee

Comment 6

5 years ago
Comment on attachment 8411644 [details] [diff] [review]
Patch v1: re-introduce a checked state for panel-menu buttons

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis, bug 979378.
User impact if declined: When in fullscreen mode, the Fullscreen button in the menu-panel does not show this state, whereas before it did. This patch solves this regression and makes sure the Fullscreen button show the 'down' state when in fullscreen mode.
Testing completed (on m-c, etc.): landed on m-c.
Risk to taking this patch (and alternatives if risky): minor.
String or IDL/UUID changes made by this patch: n/a.
Attachment #8411644 - Flags: approval-mozilla-aurora?
Attachment #8411644 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Assignee

Comment 7

5 years ago
Please note that approval was granted for Fx 30, thus needs to be landed on beta, if I'm correct.
Keywords: checkin-needed
FWIW, last I heard, Australis devs are still handling their own uplifts.
Keywords: checkin-needed
Whiteboard: [Australis:P4-] → [Australis:P4-][checkin-needed-beta]
Assignee

Updated

5 years ago
Whiteboard: [Australis:P4-][checkin-needed-beta] → [Australis:P4-]
Depends on: 1004460
Flags: in-testsuite?
Keywords: verifyme
Verified fixed on Firefox 31 Beta 4 (Build ID: 20140623175014) using: Windows 7 64-bit, Mac OS X 10.9.2 and Ubuntu 14.04 LTS 32-bit.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.