Closed Bug 1001209 Opened 6 years ago Closed 6 years ago

Trying to flash a customization on master will result in the phone getting stuck on the Firefox logo screen

Categories

(Firefox OS Graveyard :: Gaia::Build, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jsmith, Unassigned)

Details

(Keywords: regression)

Build - 2.0 4/24/2014 Open C Build

STR

1. Setup your build according to https://wiki.mozilla.org/B2G/QA/Customizations#Build_Setup
2. Startup the device

Expected

The FTE should appear.

Actual

The phone gets stuck at the Firefox boot logo.
Yuren - I'm blocked on doing asm.js app testing due to this bug. Can you help look into this?
blocking-b2g: --- → 2.0?
Flags: needinfo?(yurenju.mozilla)
Keywords: regression
George, could you help on this issue?
Flags: needinfo?(yurenju.mozilla) → needinfo?(gduan)
Hi Jason,

I tried those steps on latest master and things work fine. So, I guess..

1. please make sure GAIA_DISTRIBUTION_DIR points to the relative path of gaia folder (if you clone qa-testcase-data to gaia folder, then you should use  GAIA_DISTRIBUTION_DIR=qa-testcase-data/customization/reference
2. please run |make clean| before |MOZILLA_OFFICIAL=1 GAIA_DISTRIBUTION_DIR=../qa-testcase-data/customization/reference make production|.

please let me know your result.
thanks.
Flags: needinfo?(gduan) → needinfo?(jsmith)
Doesn't work for me. I just retested on trunk & still got the same results. What customization did you use to test this?
Flags: needinfo?(jsmith) → needinfo?(gduan)
(In reply to Jason Smith [:jsmith] from comment #4)
> Doesn't work for me. I just retested on trunk & still got the same results.
> What customization did you use to test this?

Note - The qa-testcase-data test case I'm using makes use of a packaged app.

https://github.com/mozilla/qa-testcase-data
Hi Jason,
I did use qa-testcase-data, but cannot reproduce it.

Could you...
1. under gaia folder, run |git clean -fdx| and try to rebuild and install.
2. if not works, I would need the log when booting up the device.
3. upload your profile folder to somewhere I can download.

Thanks.
Flags: needinfo?(gduan)
Flags: needinfo?(jsmith)
Weird - today it works fine on Open C & Buri.
Status: NEW → RESOLVED
blocking-b2g: 2.0? → ---
Closed: 6 years ago
Flags: needinfo?(jsmith)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.