Closed Bug 1001236 Opened 6 years ago Closed 4 years ago

crash in mozalloc_abort(char const*) | mozalloc_handle_oom(unsigned int) | moz_xmalloc | mozilla::FileBlockCache::BlockChange::BlockChange(unsigned char const*)

Categories

(Core :: Audio/Video: Playback, defect, P5)

All
Android
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox28 --- affected
firefox29 --- affected
firefox30 --- affected
firefox31 --- affected
fennec + ---

People

(Reporter: kbrosnan, Assigned: eflores)

Details

(Keywords: crash)

Crash Data

Attachments

(2 files)

This bug was filed from the Socorro interface and is 
report bp-a56ce0dd-86ae-4021-83dd-cc2812140425.
=============================================================

Crash playing back mostly mp3 media. Happens on Android 4.2 and higher. Slightly more prevalent on Nexus devices though the device list is quite large and not specific to a device, oem or chipset.

I am able to reproduce this by having an email with several pages that contain mp3s and consecutively opening them till Firefox crashes.
This is on the edge of a top crash on beta #11 for beta 8. #18 in release.
tracking-fennec: --- → ?
Flags: needinfo?(edwin)
Attached patch 1001236.patchSplinter Review
I can't reproduce this, but it looks like these allocations should be fallible anyway.

Kevin, could you try this build, please:

http://people.mozilla.org/~eflores/apk/fennec-31.0a1.en-US.android-arm.apk
Flags: needinfo?(edwin) → needinfo?(kbrosnan)
Interesting. These seem to be largely streaming links.
tracking-fennec: ? → +
Assignee: nobody → edwin
Kevin, I'm still having some trouble reproducing this; could you be more specific about STR here?

Does it happen when you open just one of these links?
How long does it take before fennec crashes?
Do you have to open many of the links to reproduce? in different tabs or just playing then clicking back?

Thanks.
Flags: needinfo?(kbrosnan)
To reproduce:
1. Set screen lock of device
2. Launch Firefox and play a streaming mp3 music
3. Lock screen
4. Unlock screen
   --> Firefox crashes.
(In reply to pcheng from comment #7)
> To reproduce:
> 1. Set screen lock of device
> 2. Launch Firefox and play a streaming mp3 music
> 3. Lock screen
> 4. Unlock screen
>    --> Firefox crashes.

I can consistently reproduce this by playing any music from music.baidu.com -> Lock screen with passcode -> unlock screen
Steps to reproduce
-------------------------------------------------------------------------------------
1. Set screen lock of device
2. Launch Firefox and play a streaming mp3 music
3. lock screen immediately after music starts ---- [IMPORTANT] 
   --> Firefox crashes after several seconds. After unlocking screen, you will see Firefox crashes.
Video of STR https://www.youtube.com/watch?v=V2rvrd6gt7c
Flags: needinfo?(kbrosnan)
filter on [mass-p5]
Priority: -- → P5
Component: Audio/Video → Audio/Video: Playback
Crash Signature: [@ mozalloc_abort(char const*) | mozalloc_handle_oom(unsigned int) | moz_xmalloc | mozilla::FileBlockCache::BlockChange::BlockChange(unsigned char const*)] → [@ mozalloc_abort(char const*) | mozalloc_handle_oom(unsigned int) | moz_xmalloc | mozilla::FileBlockCache::BlockChange::BlockChange(unsigned char const*)] [@ mozalloc_abort | mozalloc_handle_oom | moz_xmalloc | mozilla::FileBlockCache::BlockChange::Bloc…
No reports in the last six months.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.