Closed Bug 1001242 Opened 7 years ago Closed 1 year ago

crash in libhwui.so@0x17d36 - Samsung Android 4.1.x crash

Categories

(Firefox for Android :: General, defect, P5)

All
Android
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox28 --- affected
firefox29 --- affected
firefox30 --- affected
firefox31 --- affected
fennec + ---

People

(Reporter: kbrosnan, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-78626a82-68fe-4c27-b758-8a8bc2140410.
=============================================================

This crash only happens on Samsung devices running Android 4.1. The only thing in the comments is that the device seems to be resource constrained lagging, slow are common in the comments. Unsure if urls are helpful the only two that seem consistent are http://www.graycell.ru/simplemask.php and https://www.facebook.com

samsung 	GT-N8000
samsung 	GT-N8010
samsung 	GT-N8013
samsung 	GT-N7000
samsung 	GT-N8020
samsung 	SPH-D710
samsung 	GT-I9105P
samsung 	GT-P6200
samsung 	GT-I9082
samsung 	GT-I9105
samsung 	GT-I9082L
samsung 	GT-P6800
samsung 	SPH-D710VMUB
samsung 	SPH-D710BST
samsung 	GT-N8005
samsung 	GT-I9080L
samsung 	SCH-I925
samsung 	SCH-R760X
samsung 	SHW-M480W
samsung 	GT-B5330
samsung 	GT-S6810L
samsung 	GT-P6200L
samsung 	GT-B5330L
samsung 	GT-S6810
samsung 	GT-S6810B
samsung 	GT-S6810P
samsung 	GT-P6210
samsung 	GT-S6810M
samsung 	SHW-M480S
samsung 	GT-S6812B
samsung 	GT-N7000B
samsung 	GT-S6810E
samsung 	SHV-E230K
samsung 	SHW-M480K
samsung 	GT-S6812
samsung 	GT-S6012
First seen in 2013-09-10 Firefox 26. Brian/Lucas any thoughts on what was added in that release?
Flags: needinfo?(lucasr.at.mozilla)
Flags: needinfo?(bnicholson)
Given the comments in snorp's link and the timeframe, bug 871651 is a very strong candidate (in particular, https://hg.mozilla.org/mozilla-central/rev/959652e54e37). Just like the comments there, we're removing a layer type, and we're doing it in an AnimationListener.
Blocks: 871651
Flags: needinfo?(bnicholson)
(In reply to Kevin Brosnan [:kbrosnan] from comment #2)
> First seen in 2013-09-10 Firefox 26. Brian/Lucas any thoughts on what was
> added in that release?

Kevin, can you reliably reproduce this on the devices mentioned above? It should be simply to write a patch that applies the solution suggested in the link snorp posted.
Flags: needinfo?(lucasr.at.mozilla) → needinfo?(kbrosnan)
This is reported from crash-stats. We have not reproduced the crash.
Flags: needinfo?(kbrosnan)
tracking-fennec: ? → +
I have an N-7000 on 4.1.2, I'll try and reproduce this.
filter on [mass-p5]
Priority: -- → P5

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.