Add support of websites to opt-out of casting videos

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: mfinkle, Assigned: mfinkle)

Tracking

Trunk
Firefox 32
x86_64
Linux
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox31 wontfix, firefox32 wontfix)

Details

Attachments

(2 attachments)

Apple introduced an attribute that many video sites are using these days:
x-webkit-airplay=allow|deny

See:
https://developer.apple.com/library/safari/documentation/AudioVideo/Conceptual/AirPlayGuide/OptingInorOutofAirPlay/OptingInorOutofAirPlay.html

We might as well support it too.

I need to add a test too.
Attachment #8412368 - Flags: review?(wjohnston)
Comment on attachment 8412368 [details] [diff] [review]
casting-optout v0.1

Review of attachment 8412368 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/chrome/content/CastingApps.js
@@ +143,5 @@
>      }
>  
> +    // Allow websites to opt-out using the Apple airplay attribute
> +    // https://developer.apple.com/library/safari/documentation/AudioVideo/Conceptual/AirPlayGuide/OptingInorOutofAirPlay/OptingInorOutofAirPlay.html
> +    if (aElement.getAttribute("x-webkit-airplay") == "deny") {

===
Attachment #8412368 - Flags: review?(wjohnston) → review+
Some simple tests. Green locally.
Assignee: nobody → mark.finkle
Attachment #8416096 - Flags: review?(wjohnston)
Comment on attachment 8416096 [details] [diff] [review]
casting-optout-tests v0.1

Review of attachment 8416096 [details] [diff] [review]:
-----------------------------------------------------------------

Nice. That was easy :)
Attachment #8416096 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/ad3355a8d31f
https://hg.mozilla.org/mozilla-central/rev/c788ef01538a
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Comment on attachment 8412368 [details] [diff] [review]
casting-optout v0.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Gives websites control over what videos can be cast, which is a feature on Fx31
Testing completed (on m-c, etc.): Working OK and has a test on m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8412368 - Flags: approval-mozilla-aurora?
Attachment #8412368 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
After talking to a few people, we decided that this code is counter to user choice, so we are backing it out until a real need arises.

https://hg.mozilla.org/integration/fx-team/rev/6c2feedbb3d6
https://hg.mozilla.org/releases/mozilla-aurora/rev/e16b9c26e3fa
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.