Better "The connection was refused when attempting to contact HOST" dialog

RESOLVED DUPLICATE of bug 28586

Status

--
enhancement
RESOLVED DUPLICATE of bug 28586
17 years ago
5 years ago

People

(Reporter: jlp.bugs, Assigned: mpt)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Now when Mozilla is unable to connect to a host (for example when connection
times out) you get a "The connection was refused when attempting to contact
HOST" dialog, when HOST is the host you are trying to connect to. When this
dialog pops up and you are working in a different window or application the
window with this dialog comes on top and when you click OK the window you were
working in before comes back to top.
This is not wery useful in my opinion as you have to remember and return to the
window that was unable to connect and do what you want. I was thinking about
adding "Do you want to retry?" text and instead of having an OK button there
would be two buttons:
Yes - Dialog closes, browser would retry to connect to the host and you would
return to the window you were working in before
No - Dialog closes, you would return to the window you were working in before or
maybe you would stay in the current browser window and do something else (which
i think is even better).

Updated

17 years ago
Whiteboard: DUPEME

Comment 1

17 years ago
I'd would prefer to do without the whole dialog. For example if I have some
known ad-servers in my hosts file pointing to localhost and I'm not running
server in my desktop I keep getting this dialog every time there should be an
add on the page. I'm aware that Mozilla supports ad blocking but keeping
ad-servers in hosts allows same blocking to apply to all my browsers. If you
really insist to keep the dialog at least there should be "Don't show this
message again" checkbox with the OK button. I'd prefer some kind of log instead
of popup dialog if I need error messages at all. If the error happens when
trying to fetch some image that has given size (and therefore there will be
empty spot on the page) it would be nice to generate and transparent image of
that size with a text "Unable to contact host %s" or something like that.

Comment 2

17 years ago
This behaviour is not specific to Win2k. I've seen it on Linux, and Win98 so it
is a 'feature' of Mozilla. I also use loopbacks as a convenient way to block
undesired content and am looking for a way to turn these alerts OFF or redirect
them--possibly to the status bar. Please cc me on any solutions you find. THANKS!

Comment 3

17 years ago
What part of the Mozilla code controls this behaviour? What preferences in the
prefs.js and user.js can manipulate popup/alert behaviour?

Comment 4

17 years ago
Try http://www.ucip.org/
I can go to this page with Internet Explorer 5.5 and Netscape 4.78, but not with
Mozilla (0.9.4)
(Reporter)

Comment 5

17 years ago
Chantal:
This bug is not about the problem you have. Try to find another bug which is
about inability to access the server or create a new bug. BTW Page
http://ucip.org/ work just fine.

Comment 6

17 years ago
The dialog is going away, which will fix the most annoying aspect of this bug 
(popping up while you're working in another window).

*** This bug has been marked as a duplicate of 28586 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.