Closed Bug 1001357 Opened 6 years ago Closed 6 years ago

[B2G][Tarako][Dialer] Sometimes call error message is not displayed

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

x86_64
Linux
defect
Not set

Tracking

(b2g-v1.3T affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v1.3T --- affected

People

(Reporter: hsinyi, Unassigned)

References

Details

Attachments

(2 files)

Tarako v1.3t, buildId: 20140424164003

STR:
1) Dial out an invalid number
2) Wait for operator releasing the call
3) From RIL log, I see modem reports 'BadNumberError' (Note, not every operator reports 'BadNumberError' in this case, but Taiwan mobile does)


Expected result:
A warning message is shown, saying it's an invalid number

Actual result:
No warning message
Not sure if this is a cert blocker...
Attached file log-noerrormsg-2
Sometimes telephony_helper receives onerror event (you could search |XXX call error|), but sometimes not even Telephony seems fire that (search |XXX notifyError|).
See Also: → 1001729
I'd like to nominate this as 1.3T+.

When I investigate bug 1001729, I noticed that sometimes Dialer doesn't receive onerror event, even rild reports a error and gecko dispatches that error.

If this issue hasn't been resolved, user will not get notified a correct error, e.g. FDN blocked, even bug 100172 and bug 100374 are fixed.
blocking-b2g: --- → 1.3T?
(In reply to Hsin-Yi Tsai  [:hsinyi] from comment #0)
> Tarako v1.3t, buildId: 20140424164003
> 
> STR:
> 1) Dial out an invalid number
> 2) Wait for operator releasing the call
> 3) From RIL log, I see modem reports 'BadNumberError' (Note, not every
> operator reports 'BadNumberError' in this case, but Taiwan mobile does)
> 
> 
> Expected result:
> A warning message is shown, saying it's an invalid number
> 
> Actual result:
> No warning message

Another STR:
1) Enabled FDN
2) Dial out a call not in the white list
Summary: [B2G][Tarako][Dialer] No error message 'invalid number' is displayed when I make a call to a bad number → [B2G][Tarako][Dialer] Sometimes call error message is not displayed
(In reply to Hsin-Yi Tsai  [:hsinyi] from comment #3)
> I'd like to nominate this as 1.3T+.
> 
> When I investigate bug 1001729, I noticed that sometimes Dialer doesn't
> receive onerror event, even rild reports a error and gecko dispatches that
> error.
> 
> If this issue hasn't been resolved, user will not get notified a correct
> error, e.g. FDN blocked, even bug 1001729 and bug 1003745 are fixed.
hi Hsinyi, is this a feature request? thanks
Flags: needinfo?(htsai)
(In reply to Joe Cheng [:jcheng] from comment #6)
> hi Hsinyi, is this a feature request? thanks

No, it's not a new feature request. Dialer has implemented it before [1] but somehow broken. So, this is about a broken feature as bug 1001729 comment 0 reports. And FDN is just one case. Another case is as my comment 0. 

[1] https://github.com/mozilla-b2g/gaia/blob/v1.3t/apps/communications/dialer/js/telephony_helper.js#L105
Flags: needinfo?(htsai)
Flags: needinfo?(jhammink)
I'm a little confused by this.   Current expected behavior is to get an announcement from the carrier "Call cannot be completed as dialed", and then call terminates.  This is how it is working on e.g. Android, Blackberry devices.  In no case am I getting a separate error message from the OS on these devices.

I will investigate this more tomorrow.
Attached file sn2.log
Flags: needinfo?(jhammink)
The fact that Carrier (in my case AT&T) sends an announcement suggests instead that they do not send 'BadNumberError' which would trigger the call error message.   I saw no such error in my logfiles.

Curiously enough, I did see this line in the log at around the time the call was terminated:

E/GeckoConsole(  591): Content JS ERROR at app://communications.gaiamobile.org/dialer/js/telephony_helper.js:124 in errorCB: Unexpected error:  UnspecifiedError

but it's possible this is unrelated.
I cannot reproduce this anymore with pvt.v130 tarako, buildID 20140505164002, version 28.1.

Close this as WORKSFORME.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
blocking-b2g: 1.3T? → ---
You need to log in before you can comment on or make changes to this bug.