Closed Bug 1001366 Opened 10 years ago Closed 10 years ago

PJS: String(x) not supported in kernel, though "" + x is

Categories

(Core :: JavaScript Engine: JIT, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: lth, Unassigned)

References

Details

Calling String(x) within the kernel causes a bailout, but using "" + x does not.  (In this case x was a small nonnegative integer.)

The test case is "Test case 4" on bug 933313, grep through the source to search for "String(sum)" within a comment.
Evidently the problem is that the String() function does not have a parallel version (we fail to analyze the call as safe in ParallelSafetyVisitor::visitCall()).
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.