Closed Bug 1001499 Opened 5 years ago Closed 5 years ago

[B2G][Tarako][Contacts] User can hit the "Link Contact" button even though there is no imported facebook contacts

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 unaffected, b2g-v1.3T affected, b2g-v1.4 unaffected, b2g-v2.0 unaffected)

RESOLVED WORKSFORME
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected
b2g-v1.4 --- unaffected
b2g-v2.0 --- unaffected

People

(Reporter: jcastro, Unassigned)

References

()

Details

(Whiteboard: [tarako-exploratory])

Attachments

(3 files)

Prerequisite:
Have no imported contacts.
User has at least one contact.

Description:
User unlocked the phone. User goes to contacts and selects a non Facebook contact. Hit the "Link Contact" button. User is shown a loading screen with a cancel button, and can sit on that screen indefinitely

Repro Steps:
1) Update a tarako to BuildID: 20140424014003
2) User goes to Contacts
3) User selects non facebook contact
4) User hits Link contact

Actual:
Goes to a loading screen, and will sit there for ever or until the user hits cancel

Expected:
A:Link Contact button is grayed out if there are no facebook contacts to link with. 
B:If its not grayed out, an error fires explaining to the user there is no contacts to link to.

1.3t Environmental Variables:
Device: tarako 1.3t MOZ
BuildID: 20140424014003
Gaia: 706f474230432c8cb01e124aee2c055ec902aa1d
Gecko: 26ef3dded9ff
Version: 28.1
Firmware Version: Sp6821a-4-18

Repro frequency: 100%
See attached: 
Video clip: https://www.youtube.com/watch?v=_UPUsrf7K_I&feature=youtu.be
Logcat
Firewatch log
Did not reproduce on a Buri with V1.3. On a buri the behavior seen is that the 'Link Contact' button is greyed out

1.3 Environmental Variables:
Device: buri 1.3 MOZ
BuildID: 20140423024002
Gaia: fb2b8e25e8095a5db49b5eb68c74b49f180605d4
Gecko: da2500909f91
Version: 28.0
Firmware Version: V1.2device.cfg
blocking-b2g: --- → 1.3T?
Whiteboard: [tarako-exploratory]
Does this reproduce on trunk or 1.4?
Keywords: qawanted
Hi,

It should be possible to link a contact at any time, it doesn't matter if you previously imported some contacts or not, I've followed the steps mentioned in the description:
1) go to Contacts
3) select a non facebook contact
3) hit Link contact

FB log in page is shown, after logging in you will see the potential matching list and you are able to link a contact, it works as expected on master build (4/25):
Device: Hamachi
BuildId: 20140425070728
Gecko: 7db76c3
Gaia: 8c5e38b
Platform version: 31.0a1
video taken on master build (4/25). Notice that in this case I was already logged in in FB so it has not been needed to do it again. Moreover, no specific matching list is shown (there is no match between the local contact and FB ones) but you are able to link the local contact with any FB one.
Keywords: qawanted
> Actual:
> Goes to a loading screen, and will sit there for ever or until the user hits cancel

ni? Tim, can someone help to look as this? thanks
Flags: needinfo?(timdream)
Ian, could you try to see if there is any error in the log?
Flags: needinfo?(timdream) → needinfo?(iliu)
Hi,

Just adding that it is working fine on today's (4/29) v1.4 build:
Device: Hamachi
BuildId: 20140429053942
Gecko: 44787e8
Gaia: cf590ec
Platform version: 30.0
I don't see any error log in the above attached file(Logcat_Link_NoContact.txt). But I get the error message as following while I click on "Link contact".

Error
Invalid App ID:123456
Flags: needinfo?(iliu)
(In reply to Ian Liu [:ianliu] from comment #9)
> Error
> Invalid App ID:123456

That means we are not using a build with Facebook App ID configured and this bug is INVALID.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #10)
> (In reply to Ian Liu [:ianliu] from comment #9)
> > Error
> > Invalid App ID:123456
> 
> That means we are not using a build with Facebook App ID configured and this
> bug is INVALID.

No, that means Ian didn't test it correctly. The builds we use are MOZILLA_OFFICIAL=1, which should have the app ID being correct.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
After verification again, I do:

* DEVICE_DEBUG=1 NOFTU=1 MOZILLA_OFFICIAL=1 make reset-gaia
* test_media/reference-workload/makeReferenceWorkload.sh medium

Build version:
Gaia      f9b62bd1135f4edf8317fff1c2947b9d99438d79
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/bc5f0e461c9e
BuildID   20140429164003
Version   28.1
ro.build.version.incremental=eng.kaizhen.20140425.155902
ro.build.date=Fri Apr 25 15:59:09 CST 2014

I'm able to go into Facebook.com page. After log-in with account, will see authentication page in Facebook page. Looks like work for me.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → WORKSFORME
blocking-b2g: 1.3T? → ---
(In reply to Ian Liu [:ianliu] from comment #12)
> After verification again, I do:
> 
> * DEVICE_DEBUG=1 NOFTU=1 MOZILLA_OFFICIAL=1 make reset-gaia
> * test_media/reference-workload/makeReferenceWorkload.sh medium

This is not a valid production build. NOFTU & reset-gaia are not valid parameters for production builds. This is also is an ineffective verification of reproduction of the issue, as we should always against a pvtbuild as well as a point of comparison. Reopening, as the testing here is not valid.
Status: RESOLVED → REOPENED
blocking-b2g: --- → 1.3T?
Resolution: WORKSFORME → ---
Naoki - Can you look at this to see if you can reproduce?
Flags: needinfo?(nhirata.bugzilla)
It worked fine for me in today's build.

I think there might be an issue with using a B-wireless network on the device.

Gaia      93002552d67b47caae387540551924afd1fea2ba
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/ba50f734b815
BuildID   20140430014008
Version   28.1
ro.build.version.incremental=eng.cltbld.20140430.124617
ro.build.date=Wed Apr 30 12:46:24 EDT 2014
Tarako

Jcastro, can you try again please?
Flags: needinfo?(nhirata.bugzilla) → needinfo?(jcastro)
Could not reproduce issue.
Attempted a reproduce on today's Tarako build. This functioned as expected. 

1.3t Environmental Variables:
Device: tarako 1.3t MOZ
BuildID: 20140430014008
Gaia: f9b62bd1135f4edf8317fff1c2947b9d99438d79
Gecko: ba50f734b815
Version: 28.1
Firmware Version: SP6821a-gonk-4.0-4-29
Flags: needinfo?(jcastro)
Status: REOPENED → RESOLVED
blocking-b2g: 1.3T? → ---
Closed: 5 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.