rewrap can duplicate text in message body

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: jhardin, Assigned: kinmoz)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Repeatedly choosing rewrap during message composition can result in message text
in the compose window being duplicated at the end of the message body.

Comment 1

17 years ago
reporter,
Please give the build id and some steps to be able to reproduce. 
QA Contact: sheelar → esther
(Reporter)

Comment 2

17 years ago
Build info:

 Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4+) Gecko/20010914

Steps to reproduce:

1. Open a new mail compose window. Delete any signature block.

2. Type in the following, INCLUDING the >:

> Now is the time for all good men to come to the aid of their country.

3. Use cut-and-paste to duplicate this line several times.

4. Select REWRAP. The text will be duplicated. Pressing REWRAP repeatedly will
add more copies of the text.

NOTE: a colleague using 0.9.3 cannot reproduce the bug using these directions.

Comment 3

17 years ago
*** Bug 105237 has been marked as a duplicate of this bug. ***
Confirming based on the duplicate.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

17 years ago
*** Bug 115464 has been marked as a duplicate of this bug. ***
Reassign to editor core
Assignee: ducarroz → kin
Component: Composition → Editor: Core
Keywords: mailtrack
Product: MailNews → Browser
QA Contact: esther → sujay
(Assignee)

Comment 7

17 years ago
I can't reproduce this with the given steps, in this bug or any of it's dups, 
in my Win32 01/24/02 Debug build.

Akkana/Joe, have you heard of, or seen this problem?

Sujay, can you repro this problem?
Whiteboard: [WORKSFORME?]
(Assignee)

Comment 8

17 years ago
Like I said above, I'm not seeing the problem, and neither is akkana. I'm going 
to close this off as worksforme. Please reopen if you can get new steps to 
relibably repro the problem.

As a side note, the only other wierdness I noticed related to rewrap was 
filed as bug 121898. 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Whiteboard: [WORKSFORME?]
(Assignee)

Comment 9

17 years ago
*** Bug 104224 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.