Closed Bug 1001621 Opened 8 years ago Closed 8 years ago

[B2G][Settings][Bluetooth] Unable to pair bluetooth devices

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed, b2g-v2.0 fixed)

VERIFIED FIXED
2.0 S1 (9may)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: jschmitt, Unassigned)

References

Details

(Keywords: regression, smoketest)

Attachments

(1 file)

Description:
Bluetooth is not pairing when trying to connect to another phone or pc.

Repro Steps:
1) Update a Open_C/Flame to BuildID: 20140425000201
2) Proceed to the Settings app
3) Open the Bluetooth settings
4) Enable bluetooth and connect to a nearby device/pc with Bluetooth enabled

Actual:
Bluetooth is not paring with the other device.

Expected:
Bluetooth pairs with other devices.

1.4 Environmental Variables:
Device: Open_C/Flame 1.4
BuildID: 20140425000201
Gaia: 4eb2393e6a5174e6c732167866aded046c49ed97
Gecko: ec8c6e42acf2
Version: 30.0a2
Firmware Version: P821A10-ENG_20140410

Notes:
Repro frequency: 100%
This issue also occurs on 1.4 Buri

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140425000201
Gaia: 4eb2393e6a5174e6c732167866aded046c49ed97
Gecko: ec8c6e42acf2
Version: 30.0a2
Firmware Version: v1.2-device.cfg
Regression.
Does not reproduce on yesterday's build - able to pair successfully. 

Open_C aurora
BuildID: 20140424000203
Gaia: b6a41ee9e2934fe9692da6fb1cb310cb759e9870
Gecko: 2e9abf89c087
Version: 30.0a2
Keywords: regression
Attached file logcat
more details here:
- Open_C is able to see other nearby devices with BT enabled
- after initiating pairing, another device will receive pairing request
- after confirming request on another device Open_C will hang on 'pairing' and then error window will pop-up "Unable to pair devices"
blocking-b2g: --- → 1.4?
note: unable to test this issue on trunk due to bug 1000961, device crashes every time when attempting to enable BT in Settings
QA Contact: jzimbrick
Not sure if this is related; I can't seem to unpair from the Open C when I initiated the bluetooth connection from another device.
As noted in comment 4, blocked from finding a window in master by bug 1000961, but there's only one commit in the provided pushlog.

Tinderbox Aurora Regression Window:

Last Working Environmental Variables:
Device: Buri
BuildID: 20140424123825
Gaia: fc95009476fac9ce205a59b237d146ca7f6f42e7
Gecko: f093d4c176a6
Version: 30.0a2
Base Image: V1.2-device.cfg

First Broken Environmental Variables:
Device: Buri
BuildID: 20140424124722
Gaia: 0a299a0f0ef33ed1dce7eb50ab900855b4d8369a
Gecko: f6aca02fd9f3
Version: 30.0a2
Base Image: V1.2-device.cfg

Last Working Gaia / First Broken Gecko: Issue does NOT occur.
Gaia: fc95009476fac9ce205a59b237d146ca7f6f42e7
Gecko: f6aca02fd9f3

First Broken Gaia / Last Working Gecko: Issue DOES occur.
Gaia: 0a299a0f0ef33ed1dce7eb50ab900855b4d8369a
Gecko: f093d4c176a6

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/fc95009476fac9ce205a59b237d146ca7f6f42e7...0a299a0f0ef33ed1dce7eb50ab900855b4d8369a
In that case, this should already fixed per the backout in bug 997791.
Blocks: 997791
Status: NEW → RESOLVED
blocking-b2g: 1.4? → 1.4+
Closed: 8 years ago
Resolution: --- → FIXED
Verifying issue is fixed on latest 1.4 Open C build

Environmental Variables:
Device: Open C v1.4 Mozilla RIL
BuildID: 20140428000206
Gaia: d23e479e8a4ce0bc620acb2d7e2f82801aa4d0ea
Gecko: 36f67ce46855
Version: 30.0a2
Firmware Version: P821A10-ENG_20140410
Status: RESOLVED → VERIFIED
Target Milestone: --- → 2.0 S1 (9may)
You need to log in before you can comment on or make changes to this bug.