need scriptable string stream implementation (must support nsIInputStream)

RESOLVED FIXED in mozilla0.9.7

Status

()

Core
XPCOM
P2
major
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Darin Fisher, Assigned: Darin Fisher)

Tracking

({arch})

Trunk
mozilla0.9.7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Assignee)

Description

16 years ago
need scriptable string stream implementation (must support nsIInputStream)
this is needed to support nsIUploadChannel usage via JS.
(Assignee)

Comment 1

16 years ago
i filed a similar bug a while back, but can't seem to find it now.  i think this
is urgently needed... as in by mozilla0.9.5.
Keywords: mozilla0.9.5
(Assignee)

Comment 2

16 years ago
-> me
Assignee: dougt → darin
(Assignee)

Updated

16 years ago
Severity: normal → major
Keywords: arch
Priority: -- → P2
Target Milestone: --- → mozilla0.9.5
(Assignee)

Comment 3

16 years ago
Created attachment 50334 [details]
nsIStringInputStream.idl
(Assignee)

Comment 4

16 years ago
dougt: can you comment on attachment 50334 [details]? thanks!

Comment 5

16 years ago
Does this interface handle double-byte strings (like Japanese)?
I expected to see wstring.

Where do I get the nsIInputStream from?

Comment 6

16 years ago
looks fine:

use the /** **/ style comments instead of the c++ // comment. 
(unless you know more about doxygen that I do, which is probably the case).

Also, I am not sure what the mantra is regarding CONTRACTID, CLASSNAME, and CID
declarations in an IDL.  Rick, Vidur?
(Assignee)

Comment 7

16 years ago
brade: you can only upload bytes to a necko channel... you will have to make
sure that the data is properly encoded before uploading.

dougt:

1- will change to /** **/ comments just to be consistent
2- followed nsILocalFile for an example of how CID, CONTRACTID, and CLASSNAME
are declared in XPCOM

Comment 8

16 years ago
This is probably something that we should freeze soon as many scripters will
begin using it.  

Comment 9

16 years ago
take a look at the bottom of
http://www.mozilla.org/projects/embedding/EmbedInterfaceFreeze.html for
information about what is needed to freeze a component...

-- rick
(Assignee)

Comment 10

16 years ago
i'm planning to just implement this interface using the impl's in
nsIStringStream.cpp for now... the nsIStringStream.h C++ api will not be touched.
we will also probably want a nsIStringOutputStream and perhaps a
nsIStringIOStream.  but, perhaps those interfaces are less urgently needed.
(Assignee)

Comment 11

16 years ago
*** Bug 100171 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 12

16 years ago
-> 0.9.6
Target Milestone: mozilla0.9.5 → mozilla0.9.6
(Assignee)

Comment 13

16 years ago
looks like i'm not going to have time for this now -> 0.9.7
Status: NEW → ASSIGNED
Target Milestone: mozilla0.9.6 → mozilla0.9.7
(Assignee)

Comment 14

16 years ago
Created attachment 58507 [details] [diff] [review]
v1.0 patch

this patch takes a slightly different approach.. see nsIStringStream.idl
(Assignee)

Comment 15

16 years ago
Comment on attachment 58507 [details] [diff] [review]
v1.0 patch

actually, this patch still needs work.. the nsIStringInputStream needs a
factory.
Attachment #58507 - Flags: needs-work+

Updated

16 years ago
Blocks: 109960
(Assignee)

Comment 16

16 years ago
Created attachment 58776 [details] [diff] [review]
v1.1 final patch

moving some files around:

nsIStringStream.h   -> nsIStringStream.idl
nsIStringStream.cpp -> nsStringStream.cpp

and created:

nsStringStream.h
Attachment #50334 - Attachment is obsolete: true
Attachment #58507 - Attachment is obsolete: true
(Assignee)

Comment 17

16 years ago
Created attachment 58784 [details] [diff] [review]
v1.2 added contributors per "cvs log" to renamed files
Attachment #58776 - Attachment is obsolete: true
(Assignee)

Comment 18

16 years ago
Comment on attachment 58784 [details] [diff] [review]
v1.2 added contributors per "cvs log" to renamed files

got an r=dougt via AIM
Attachment #58784 - Flags: review+

Comment 19

16 years ago
Comment on attachment 58784 [details] [diff] [review]
v1.2 added contributors per "cvs log" to renamed files

sr=rpotts@netscape.com
Attachment #58784 - Flags: superreview+
(Assignee)

Comment 20

16 years ago
fixed-on-trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

16 years ago
Blocks: 108966
You need to log in before you can comment on or make changes to this bug.