Closed Bug 1001742 Opened 6 years ago Closed 6 years ago

[email/activesync] Body fetch map fail on some text/html messages (example is a message from twitter), which manifests as a load taking forever.

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 affected, b2g-v1.3T affected)

RESOLVED DUPLICATE of bug 1009422
Tracking Status
b2g-v1.3 --- affected
b2g-v1.3T --- affected

People

(Reporter: dharris, Unassigned)

References

()

Details

(Whiteboard: [tarako-exploratory])

Attachments

(2 files)

Attached file Logcat, Firewatch
Description:
When the user tries to view e-mails, some of the e-mails will never open reguardless of restarting the app or the phone.

Prerequisite: Be connected to wifi, Have an e-mail set up.

Repro Steps:
1) Update a Tarako to BuildID: 20140424014003
2) Open the E-mail app
3) Tap on an Email to open it

Actual:
The E-mail will never open and sometimes the email app will crash

Expected:
The user is able to view the e-mail without any issues

1.3t Environmental Variables:
Device: Tarako 1.3t
BuildID: 20140424014003
Gaia: 706f474230432c8cb01e124aee2c055ec902aa1d
Gecko: 26ef3dded9ff
Version: 28.1
Firmware Version: sp6821


Keywords: Inconsistent, Unresponsive, Loading, Closing, Stuck, Hotmail, Gmail, OOM, Out of Memory


Notes: Certain E-mails will open every time, and certain E-mails will never open.


Repro frequency: 40%
See attached: Logcat, Firewatch, Video - http://youtu.be/GIQX44IopwA
This might be related to bug 998395

We'll need to get more information
https://wiki.mozilla.org/Gaia/Email/RequiredBugInfo

dharris, could you please help provide the information as per above?
Flags: needinfo?(dharris)
Keywords: qawanted
This was confirmed happening on 1.3, right?
The log (thank you!) indicates that ActiveSync is failing to fetch the body for the message in question.  That's why we keep spinning.  I believe the reported crash is in fact the existing bug/known limitation that the email app gets killed when the phone goes to sleep and email gets backgrounded.

As requested on https://wiki.mozilla.org/Gaia/Email/RequiredBugInfo, please provide the email domain in use.  From your keywords, I see you mentioning Gmail, which concerns me since ActiveSync is throwing the error and we absolutely do not support ActiveSync on gmail.

Also, it would be very helpful to have a copy of the message.  Please follow the steps at https://wiki.mozilla.org/Gaia/Email/ProvidingEmailsForDebugging and either attach the file here as an attachment or email it to asuth@mozilla.com.
The above issue does occur on the Buri 1.3

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140423024002
Gaia: fb2b8e25e8095a5db49b5eb68c74b49f180605d4
Gecko: da2500909f91
Version: 28.0
Firmware Version: v1.2-device.cfg

This issue seems to occur on both gmail.com (Account type: Activesync) and hotmail.com (Account type: IMAP+SMTP) e-mail domains. I will note that it is more consistent on the hotmail.com domains. Also I was able to confirm that the issue is reproducible with a stable internet connection

The e-mail I am using is qatestdharris@hotmail.com and I have attached an e-mail that does not open as a reference.
Flags: needinfo?(dharris)
Keywords: qawanted
Are you sure you have the account types matched up correctly?  You would have had to manually configure both of the accounts to get into that situation.  If so:
* We don't and won't support Activesync on gmail.com ever.  Please do not test in this configuration.
* We do want to support IMAP+SMTP on hotmail.com but haven't validated it yet.  That's bug 958614.

If you matched them up correctly, then we should make this bug block bug 958614 since the mail you provided (thanks!) would be a good one to help us validate.  Also, there would be nothing actionable on this bug since we will not change hotmail.com to use IMAP on any 1.3 branches.
Flags: needinfo?(dharris)
Whoops you are right Andrew I did have the account types matched up backwards, they do look like this:

Hotmail.com (Account type: Activesync)
Gmail.com (Account type: IMAP+SMTP)
Flags: needinfo?(dharris)
All the log excerpts are for Activesync and look like this:
===
04-25 16:14:55.349   826   922 I Gecko   : WLOG: runOp(do: {"type":"downloadBodies","longtermId":"0/D","lifecycle":"do","localStatus":"done","server
Status":"doing","tryCount":0,"humanOp":"downloadBodies","messages":[{"s)
04-25 16:14:55.649   826   826 I GeckoDump: LOG: pushCard for type: message_reader
04-25 16:14:56.369   826   922 I Gecko   : WLOG: queueOp 0 downloadBodyReps
04-25 16:14:57.909   826   826 I GeckoDump: ERR: onerror reporting: bodyContent is undefined @ app://email.gaiamobile.org/js/ext/mailapi/activesync/
configurator.js : 1592
===

So at first glance I don't think this is related to the HTML sanitizer.  I'm taking this for now to repro and investigate a little bit more.  This probably will just end up being a case where we need a guard and maybe hotmail.com/outlook.com doesn't like the HTML message.  (In which case we may need to fall back to text/plain.)
Assignee: nobody → bugmail
Status: NEW → ASSIGNED
Summary: [B2G][E-Mail] When Trying to open an E-mail it will get stuck on a loading screen and crash → [email/activesync] Body fetch map fail on some text/html messages (example is a message from twitter), which manifests as a load taking forever.
I'm having trouble reproducing this on trunk (not that trunk should matter), but I'm unable to create the exact situation.  I tried to use IMAP APPEND to cram the message into my hotmail account, but the message doesn't show up for the ActiveSync protocol.  The hotmail/live.com webmail UI seems fine with the message though, as does our client via IMAP.  I tried some various other hacks too, but getting exact fidelity is turning out to be a bit of a hassle and I'm now suspecting this might be emergent fallout from bug 825538 anyways.  So I subscribed my hotmail account to twitter spam and we'll see how that goes over the next few days.
Assignee: bugmail → nobody
Status: ASSIGNED → NEW
This has now been reported in a different guise on v1.4.  I am consolidating via dupe to a new bug that I will work but may reopen this if it turns out I am mistaking about the underlying problem.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1009422
Note for posterity: twitter spam back then and checked just now still shows no sign of causing failures for us, implying the duping is accurate.
You need to log in before you can comment on or make changes to this bug.