Record total RAM and pagefile size in crash reports

RESOLVED FIXED in Firefox 30

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: dmajor, Assigned: dmajor)

Tracking

unspecified
mozilla32
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox30 fixed, firefox31 fixed, firefox32 fixed, b2g-v1.4 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

Assignee

Description

5 years ago
This can help us understand what proportion of out-of-physical-memory errors come from too low pagefile settings.

In my brief testing, ullTotalPageFile is the combined size of RAM + pagefile. Subtracting ullTotalPhys gets the size of the pagefile alone.
Assignee

Comment 1

5 years ago
Posted patch PatchSplinter Review
Attachment #8413091 - Flags: review?(benjamin)

Updated

5 years ago
Attachment #8413091 - Flags: review?(benjamin) → review+
Assignee

Updated

5 years ago
Assignee: nobody → dmajor
https://hg.mozilla.org/mozilla-central/rev/62f2593a6412
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
Assignee

Comment 4

5 years ago
Comment on attachment 8413091 [details] [diff] [review]
Patch

Nominating in order to get more data faster. This isn't really a bugfix but it's very safe.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a, new code
User impact if declined: Less OOM data
Testing completed (on m-c, etc.): A few days on nightly, no issues on mozillazine
Risk to taking this patch (and alternatives if risky): Very low risk, the data was already calculated, this patch is just logging
String or IDL/UUID changes made by this patch: None
Attachment #8413091 - Flags: approval-mozilla-beta?
Attachment #8413091 - Flags: approval-mozilla-aurora?
Attachment #8413091 - Flags: approval-mozilla-beta?
Attachment #8413091 - Flags: approval-mozilla-beta+
Attachment #8413091 - Flags: approval-mozilla-aurora?
Attachment #8413091 - Flags: approval-mozilla-aurora+
Whiteboard: verifyme
Is there any need for manual testing here? If so can you offer some guidance?
Flags: needinfo?(dmajor)

Comment 8

5 years ago
dmajor did you file a socorro bug to have these fields whitelisted and search-indexed?
Keywords: verifyme
Whiteboard: verifyme
Assignee

Updated

5 years ago
Blocks: 1006898
Assignee

Comment 9

5 years ago
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #7)
> Is there any need for manual testing here? If so can you offer some guidance?

It's not really necessary, but if you want, you can load a crash report from a recent Win32 nightly and see that the "Metadata" tab has fields "TotalPageFile" and "TotalPhysicalMemory".

(In reply to Benjamin Smedberg  [:bsmedberg] from comment #8)
> dmajor did you file a socorro bug to have these fields whitelisted and
> search-indexed?

Just opened bug 1006898.
Flags: needinfo?(dmajor)
(In reply to David Major [:dmajor] (UTC+12) from comment #9)
> It's not really necessary, but if you want, you can load a crash report from
> a recent Win32 nightly and see that the "Metadata" tab has fields
> "TotalPageFile" and "TotalPhysicalMemory".
Don't see any of those fields - 32.0a1 (2014-05-07), Win 7 x64.
https://crash-stats.mozilla.com/report/index/196fec9e-ae8d-46bc-acd8-d07542140507
Flags: needinfo?(dmajor)
Assignee

Comment 11

5 years ago
Ah, maybe it's restricted currently... you should be able to see them after bug 1006898 is fixed.
Flags: needinfo?(dmajor)
Removing "verifyme" keyword, since bug 1006898 is still open, while we got the Firefox 30 RC.
Keywords: verifyme
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.