Closed Bug 1001794 Opened 6 years ago Closed 6 years ago

"Help, About" does not show proper update channel in 29rc updated on beta channel

Categories

(Firefox :: General, defect, minor)

28 Branch
defect
Not set
minor

Tracking

()

RESOLVED FIXED
Firefox 32

People

(Reporter: ToddAndMargo, Assigned: yfdyh000)

References

Details

Attachments

(2 files, 1 obsolete file)

Attached image HelpAbout.29b9.png
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20140314220517

Steps to reproduce:

Hi,

I had a number of customers on Firefox 28, 32 bit for Windows that were experiences massive slow downs and large black areas of their screen when pulling Firefox from the background.  To correct this, I installed 

http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/29.0b9/win32/en-US/Firefox Setup 29.0b9.exe 

Now they work perfectly, thank you!

But something happened that caused release channel confusion.  After installing 29b9 and going to "Help, About", it said that they were on the beta channel.  So far so good.  

Then "Help, About" installed a quick update and asked to reboot.  After the reboot, "Help, About" said they were on 29 with no other indication that
they were still on the "beta" channel.

But "About:config" shows them on the "beta" channel: app.update.channel;beta.

Bug: "Help, About" should have showed them still on the "beta" channel.
I have attached a screen shot of the missing "beta" channel "Help, About" (after the update and restart).  This caused a lot of confusion, until a guy over on the mozilla.support.firefox group told me to look at app.update.channel.  And, "Help, about" can not really be trusted.

Do I presume correctly that all I have to do is change app.update.channel to "release" to put them back on the normal channel?  (I know, a tech support question, but please indulge me.)

Many thanks,
-T
The beta channel installs the release candidate builds (which, barring any humongous issues, will be released as Firefox 29 the coming Tuesday). I believe that that is why there is update channel confusion. I agree that it's confusing. I don't know why it is this way. Rob might know.

(In reply to Todd from comment #0)
> Do I presume correctly that all I have to do is change app.update.channel to
> "release" to put them back on the normal channel?  (I know, a tech support
> question, but please indulge me.)

I *believe* this is correct, but I'll let Rob confirm that, too.
Flags: needinfo?(robert.strong.bugs)
(In reply to Todd from comment #0)
> Created attachment 8413139 [details]
> HelpAbout.29b9.png
> 
> User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:28.0) Gecko/20100101
> Firefox/28.0 (Beta/Release)
> Build ID: 20140314220517
> 
> Steps to reproduce:
> 
> Hi,
> 
> I had a number of customers on Firefox 28, 32 bit for Windows that were
> experiences massive slow downs and large black areas of their screen when
> pulling Firefox from the background.  To correct this, I installed 
> 
> http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/29.0b9/win32/en-US/
> Firefox Setup 29.0b9.exe 
> 
> Now they work perfectly, thank you!
> 
> But something happened that caused release channel confusion.  After
> installing 29b9 and going to "Help, About", it said that they were on the
> beta channel.  So far so good.  
> 
> Then "Help, About" installed a quick update and asked to reboot.  After the
> reboot, "Help, About" said they were on 29 with no other indication that
> they were still on the "beta" channel.
> 
> But "About:config" shows them on the "beta" channel: app.update.channel;beta.
> 
> Bug: "Help, About" should have showed them still on the "beta" channel.
> I have attached a screen shot of the missing "beta" channel "Help, About"
> (after the update and restart).  This caused a lot of confusion, until a guy
> over on the mozilla.support.firefox group told me to look at
> app.update.channel.  And, "Help, about" can not really be trusted.
What is displayed in about:config for the app.update.channel value?
What is displayed in the application.ini file for the value of SourceRepository under [App]?

> 
> Do I presume correctly that all I have to do is change app.update.channel to
> "release" to put them back on the normal channel?  (I know, a tech support
> question, but please indulge me.)
No, you have to install a build for the release channel.
Flags: needinfo?(robert.strong.bugs)
Hi Robert,

> What is displayed in about:config for the app.update.channel value?

"But "About:config" shows them on the "beta" channel: app.update.channel;beta."
app.update.channel  default  sting   beta

> What is displayed in the application.ini file for the value of SourceRepository under [App]?

[App]
Vendor=Mozilla
Name=Firefox
Version=29.0
BuildID=20140421221237
SourceRepository=https://hg.mozilla.org/releases/mozilla-release
SourceStamp=f60bc49e6bd5
ID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}


I also looked this up:

about:buildconfig
Build Machine

W64-IX-SLAVE136
Source

Built from https://hg.mozilla.org/releases/mozilla-release/rev/f60bc49e6bd5
Build platform
target
i686-pc-mingw32
Build tools
Compiler 	Version 	Compiler flags
cl 	16.00.30319.01 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -wd4244 -wd4819 -we4553
cl 	16.00.30319.01 	-wd4099 -TP -nologo -W3 -Gy -Fdgenerated.pdb -wd4251 -wd4244 -wd4345 -wd4351 -wd4482 -wd4800 -wd4819 -we4553 -GR- -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -O1 -Oy
Configure arguments

--enable-crashreporter --enable-release --enable-update-channel=release --enable-update-packaging --enable-jemalloc --with-google-api-keyfile=/c/builds/gapi.data --enable-warnings-as-errors --enable-official-branding
about:
Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:29.0) Gecko/20100101 Firefox/29.0
Nick, do you think this a side affect of how you are testing releases on beta? I downloaded the 29b9 build and wasn't offered an update so I can't verify.

Note: displaying the channel was implemented in bug 659972.
Flags: needinfo?(nthomas)
Yes, I think so. 29.0b9 installed, then updated to 29.0 RC1, so
 http://hg.mozilla.org/releases/mozilla-release/file/default/browser/base/content/aboutDialog.js#l55
comes into play.
Flags: needinfo?(nthomas)
So, with the way updates on beta are performed in order to test RC's (e.g. beta builds are updated to release bits) it is possible for the channel information in the about dialog as implemented in bug 659972 to not have any indication that the Firefox installation is on beta.
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
Flags: firefox-backlog?
Because the "--enable-update-channel=release", the #currentChannelText is excluded in aboutDialog.xul, see https://hg.mozilla.org/releases/mozilla-release/file/205f9a8e2840/browser/base/content/aboutDialog.xul#l111.

an idea, remove the #if and using js to control its display.
Severity: normal → minor
Attached patch patch (obsolete) — Splinter Review
p.s. No hide esr or default, I guess this is the expected result.
ref: http://kb.mozillazine.org/App.update.channel
Attachment #8413346 - Flags: review?(gavin.sharp)
Blocks: 848451
Now that FF 29.0 is released, do I still need to install FF 29.0 over those installations I have out there with FF 29b9?  Ordinarily I would, but does this bug let me off just this once?  These customers need to be on the general release channel.
It doesn't. Those systems are on the beta channel and to get them on the release channel the release build will need to be installed. There is at least one place that I know of in the code that is different between the beta and release builds.
Flags: firefox-backlog? → firefox-backlog+
This is a regression from bug 848451
Flags: needinfo?(jaws)
Comment on attachment 8413346 [details] [diff] [review]
patch

This looks right to me - thanks!

This about dialog code should be using UpdateChannel.jsm - perhaps you're interested in patching that as well, in a new bug?
Attachment #8413346 - Flags: review?(gavin.sharp) → review+
Flags: needinfo?(jaws)
Summary: "Help, About" does not show proper release channel in 29b9 → "Help, About" does not show proper update channel in 29rc updated on beta channel
I noticed a glitch, bad Parent. it can be forced to push?
or please review the new patch, only the Parent changed, thanks.
Attachment #8413346 - Attachment is obsolete: true
Attachment #8415675 - Flags: review?(gavin.sharp)
(In reply to :Gavin Sharp (email gavin@gavinsharp.com) from comment #13)
> This about dialog code should be using UpdateChannel.jsm - perhaps you're
> interested in patching that as well, in a new bug?

I can't understand, sorry for my ability now.
Gavin/Robert - what is the desired behavior for partner builds ? Eg channels like release-cck-yandex returned by UpdateChannel.jsm. I'd suggest hiding the channel if it starts with 'release', rather than matching exactly.
It is often difficult for people to know if they are on a partner build and this would be a way for people troubleshooting to find out but I'll leave that to Gavin.
There is a couple of lines that appear in About for partner repacks, which may be clearer to users than a channel, but I don't know how troubleshooting normally goes.
Comment on attachment 8415675 [details] [diff] [review]
correct parent for patch

I had considered .beginsWith("release"), but since this code is getting app.update.channel directly and not using UpdateChannel.jsm, it wouldn't be seeing partner update channels additions anyhow, so it doesn't matter.

When we move to UpdateChannel.jsm we'll want to consider the behavior we want for partner repacks.
Attachment #8415675 - Flags: review?(gavin.sharp) → review+
I filed bug 1004903 about using UpdateChannel.jsm.
Assignee: nobody → yfdyh000
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/4818ff85895c
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 32
Hi,

while trying to verify it, I've noted that the reporter is speaking about Windows x86_32 machines, but
the Platform field says "x86_64 / Linux". 
Should I change it, so that it will be verified against the right platform? (Yeah, I know kind of dumb question, but I guess you all may have other reasons to not change it and I wanted to be sure)


Cheers,
Francesca
Flags: needinfo?(yfdyh000)
(In reply to Francesca Ciceri [:madamezou] from comment #24)
> Hi,
> 
> while trying to verify it, I've noted that the reporter is speaking about
> Windows x86_32 machines, but
> the Platform field says "x86_64 / Linux". 
> Should I change it, so that it will be verified against the right platform?
> (Yeah, I know kind of dumb question, but I guess you all may have other
> reasons to not change it and I wanted to be sure)

I don't mind, but I think it is applicable to all platforms, and I'm not sure changing the field is beneficial.
Flags: needinfo?(yfdyh000)
OS: Linux → All
Hardware: x86_64 → All
You need to log in before you can comment on or make changes to this bug.