If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Installer: plugin installer never progresses past Finished FTP Transaction

RESOLVED WONTFIX

Status

SeaMonkey
Installer
--
major
RESOLVED WONTFIX
16 years ago
3 years ago

People

(Reporter: Jay Ballinger, Assigned: dveditz)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091303

Trying to download Java2 Plugin for windows (from
www.netscape.com/plugins/jvm.html). The Software Installation process progresses
to the "Downloading..." step and the progress notes reported connecting,
transferring, and then immediately reported "Finished FTP Transaction".

However, nothing happens after that. The original browser window is free to do
other browsing, but the installation never completes. (Windows Task Manager
reports the Software Installer as running.)

My observation hints that the file transfer never took place. The time elapsed
between connecting and reporting finishing was just way too fast - even for
Mozilla. :)

Reproducible: Always
Steps to Reproduce:
1. Browse to www.netscape.com/plugins/jvm.html
2. Click Java 2 Windows Plug-in button
3. Click OK on Software Installation Items to Install dialog
4. Watch as progress notes flip from Beginning FTP Transaction, through
connecting, to Finished FTP Transaction very quickly
5. Continue watching as nothing else happens regarding the installation

Actual Results:  Software Dialog box remains with "Finished FTP Transaction"
status. Original browser window free to continue browsing.

Expected Results:  Plugin installation to be completed and browser directed to
installer success page.

This worked for my RedHat 6.x RPM install (0.94). But it doesn't work for my
Win2K - go figure.

Comment 1

16 years ago
confirming on mozilla nightly 2001100303
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: bugzilla → gbush

Comment 2

16 years ago
reporter, are you still seeing this problem with the latest builds?
Assignee: ssu → dprice
(Reporter)

Comment 3

16 years ago
No, not seeing problem with build 2001101117. This is because the download
completes as expected.

Here's some more info, though, regarding my initial bug report...

After launching the browser, the installation attempt of the java plugin would
fail as described (the installer ftp process running too quickly). However, I
would receive an additional browser window with an installation failure message.

It's when I did not quit mozilla but tried the download again would it never
progress to the installation failure page. It's at this point it would just stop
with "Finished FTP transaction."

I suspect that the plugin was not at the location the installer expected to find
it in the previous build.

Comment 4

16 years ago
can this be resolved now?  it worksforme
(Reporter)

Comment 5

16 years ago
Yes, it can be resolved. The download now finds the plugin on the FTP server. I
don't know if this was a real code fix or a file download location fix. But it
worksforme now.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 6

16 years ago
verified
Status: RESOLVED → VERIFIED

Comment 7

16 years ago
This bug seems to have resurfaced in build 202040103.

In this case the installer hangs with the file "nearly" downloaded, nothing more
happens.

Java IS installed, Netscape 4.79 works with it.

Otherwise it looks very closely like this bug.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---

Comment 8

16 years ago
not installer
Assignee: dprice → dveditz
Status: REOPENED → NEW
Component: Installer → Installer: XPI Packages
QA Contact: gbush → ktrina
Product: Browser → Seamonkey
(Assignee)

Comment 9

10 years ago
The xpinstall script engine has been removed from the trunk, bugs in it are obsolete.
Status: NEW → RESOLVED
Last Resolved: 16 years ago10 years ago
Resolution: --- → WONTFIX

Updated

9 years ago
Component: Installer: XPI Packages → Installer
QA Contact: ktrina → general
Created attachment 8413325 [details] [review]
Link to Github pull-request: https://github.com/mozilla/addon-sdk/pull/1476
Attachment #8413325 - Flags: review?(rFobic)
Comment on attachment 8413325 [details] [review]
Link to Github pull-request: https://github.com/mozilla/addon-sdk/pull/1476

Sorry, wrong wrong bug. Not sure How I can remove the attachment.
Attachment #8413325 - Attachment description: pull/1476 → Link to Github pull-request: https://github.com/mozilla/addon-sdk/pull/1476
Attachment #8413325 - Flags: review?(rFobic)
You need to log in before you can comment on or make changes to this bug.