Closed Bug 1002277 Opened 6 years ago Closed 6 years ago

Bug 984537 broke non-ion builds

Categories

(Core :: JavaScript Engine: JIT, defect)

Other
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla32
Tracking Status
firefox31 --- fixed
firefox32 --- fixed

People

(Reporter: stevensn, Assigned: stevensn)

References

Details

(Whiteboard: [qa-] )

Attachments

(1 file)

Bug 984537 broke non-ion builds

 /media/nfs/usb_drive_src/firefox/mozilla-central-hg/src/js/src/jsgc.cpp: In function ‘bool BeginMarkPhase(JSRuntime*)’:
 7:34.45 /media/nfs/usb_drive_src/firefox/mozilla-central-hg/src/js/src/jsgc.cpp:2774:35: error: ‘TopmostJitActivationCompartment’ is not a member of ‘js::jit’
 7:34.45 In file included from /home/ssinger/build-out.ppc64/js/src/Unified_cpp_js_src2.cpp:184:0:
Attachment #8413461 - Flags: review?(bhackett1024)
Attachment #8413461 - Flags: review?(bhackett1024) → review+
Keywords: checkin-needed
(In reply to Carsten Book [:Tomcat] from comment #2)
> https://hg.mozilla.org/integration/mozilla-inbound/rev/31929d871cad

sorry had to back this out since i was thinking this caused a mochitest dt3 orange. But turned out that a push from jandem caused this, so re-checkedin this as https://hg.mozilla.org/integration/mozilla-inbound/rev/0014c1997618
https://hg.mozilla.org/mozilla-central/rev/0014c1997618
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
Comment on attachment 8413461 [details] [diff] [review]
1002277_fix_nonion.diff

[Approval Request Comment]
Bug caused by (feature/regressing bug #):  Bug 984537
User impact if declined: non asmjs architectures won't build
Testing completed (on m-c, etc.): tested on m-c
Risk to taking this patch (and alternatives if risky):  low, just adding an #ifdef that is NPOTB-tier1
String or IDL/UUID changes made by this patch:
Attachment #8413461 - Flags: approval-mozilla-aurora?
Attachment #8413461 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.