Closed Bug 1002316 Opened 6 years ago Closed 6 years ago

[Tarako][Audio]Suspend screen on any app and encounter LMK, homescreen will go into content audio channel after awake screen

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3T verified, b2g-v1.4 verified, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S5 (4july)
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- verified
b2g-v1.4 --- verified
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: mlien, Assigned: alive)

Details

(Whiteboard: [FT:System-Platform])

Attachments

(1 file)

[Description]
If suspend screen or screen timeout on any app then encounter LMK, homescreen's audio channel will get incorrect after awake and unlock screen

[Device]
  Tarako
---------------------------------------------
[Reproduction build] - 0417pac + PVT v1.3T
  Gaia      4dd06db93607f55694953fe60751eddb4bbb5afc
  Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/db579b1c75ed
  BuildID   20140427164001
  Version   28.1

---------------------------------------------
[Reproduce Steps]
  1. Adjust volume on homescreen (should be notification channel)
  2. Launch Settings/Gallery app
  3. Suspend screen or wait screen timeout
  4. Awake and unlock screen (will show homescreen)
  5. Verify audio channel
---------------------------------------------
[Expected Result]
  Homescreen still in correct audio channel
---------------------------------------------
[Actual Result]
  If step 3 encounter LMK to kill app, awake and unlock screen to homescreen will find its audio is content channel
---------------------------------------------
[Reproduce Rate]
  100%
ni? Alive

triage: 1.3T+ or else user may not be able to adjust the volume of the ring tone
blocking-b2g: 1.3T? → 1.3T+
Flags: needinfo?(alive)
Assignee: nobody → alive
Flags: needinfo?(alive)
Sound manager should care homescreen window state change event.
Attachment #8413636 - Flags: review?(timdream)
We will need uplift to v1.4/v2.0
Attachment #8413636 - Flags: review?(timdream) → review+
Component: AudioChannel → Gaia::System
Whiteboard: [FT:System-Platform]
v1.3t https://github.com/mozilla-b2g/gaia/commit/99d36ea9325d8112e78c0f19ef64c71441e91b92
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
verified and fixed with below build
Gaia      fabc8154b31178515795b0a32068257fd5a16269
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/a500e34d8819
BuildID   20140511164002
Version   28.1
Status: RESOLVED → VERIFIED
Comment on attachment 8413636 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/18736

Asking for uplift approval as per Alives comments in https://bugzilla.mozilla.org/show_bug.cgi?id=1002316#c3

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: user may not be able to adjust the volume of the ring tone
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low, no regressions caused, patch is small, just listening to one event
[String changes made]:
Attachment #8413636 - Flags: approval-gaia-v1.4?
QA,

Please verify the same upon landing.
Keywords: verifyme
Attachment #8413636 - Flags: approval-gaia-v1.4? → approval-gaia-v1.4+
v1.4: https://github.com/mozilla-b2g/gaia/commit/6b4a17690d76339d911b4feec9e6fec80cc63cf8

Note that this will still need approval to land on v2.0. And what about master?
Flags: needinfo?(alive)
Target Milestone: --- → 2.0 S5 (4july)
We will need for 1.4 because dolphin will have the same issue and it's using 1.4
For 2.0 I think we will still have low end device to take so let's also do it.
Flags: needinfo?(alive)
Comment on attachment 8413636 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/18736

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: user cannot use volume button correctly if homescreen is killed by LMK
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky): no, small patch
[String changes made]:
Attachment #8413636 - Flags: approval-gaia-v2.0?
alive, is this already on gaia master to resolve on 2.1?
Flags: needinfo?(alive)
(In reply to bhavana bajaj [:bajaj] [NOT reading Bugmail, needInfo please] from comment #11)
> alive, is this already on gaia master to resolve on 2.1?

Not yet.
Flags: needinfo?(alive)
Ryan, this patch is safe to be cherry-pick-ed to master, do you want me to do it or you could help?
Flags: needinfo?(ryanvm)
I'm on PTO today, so please land this on master if you're able.
Flags: needinfo?(ryanvm)
Comment on attachment 8413636 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/18736

alive, is going to land this on master and 2.0
Attachment #8413636 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+
Issue is verfied fixed on Flame 1.4, Flame 2.0, and Flame 2.1.

Homescreen still in correct audio channel after LMK.

Device: Flame 1.4 (256mb, JB Base, Shallow Flash)
BuildID: 20141125000201
Gaia: 22c80a708329321a2fdeed4ece019498c0cec90d
Gecko: 429d90dd383c
Version: 30.0 (1.4) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141121000203
Gaia: 626d4d11a8c7e55022c1f364abb72ea340e2f1e7
Gecko: 74a294e72d0a
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141125001201
Gaia: 1bdd49770e2cb7a7321e6202c9bf036ab5d8f200
Gecko: db893274d9a6
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.