window position remembered only for most recently opened window

RESOLVED DUPLICATE of bug 86955

Status

()

Core
XUL
--
minor
RESOLVED DUPLICATE of bug 86955
17 years ago
17 years ago

People

(Reporter: John Gruenenfelder, Assigned: asa)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
In Windows, I have my Mozilla browser window NOT maximized, but taking up most
of the screen.  It is positioned at +0+0 and extends down the taskbar.  This is
where I like it to stay.

However, in recent builds of Mozilla the position stored in the user data upon
exit stores the position of the most recently opened window.  Since a newly
opened window gets an X offset of at least +20 (don't know exactly how much),
when I quit, this new position is stored, rather than +0+0.

The old behavior was for me to close the window at +0+0 LAST, thus saving its
position info.  I still close that window last, but its position info is ignored.

Comment 1

17 years ago
Reporter, have you tried the latest builds?  This sounds like a dupe of bug
86955, which is mostly fixed.

->XP Toolkit/Widgets
Component: Browser-General → XP Toolkit/Widgets
(Reporter)

Comment 2

17 years ago
Yes, this bug seems to be a duplicate of the other bug.  The problem in that one
matches mine exactly.

I believe it was either 0.9.2 or 0.9.3 when the problem appeared.  Now I'm using
0.9.4 and it is still there.  One note to make, though, is that going from 0.9.3
-> 0.9.4, I didn't delete the old preferences/local data.  I did delete it when
going from 0.9.2 -> 0.9.3.  Don't know if that makes a difference.
(Assignee)

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 86955 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.