Closed Bug 1003034 Opened 8 years ago Closed 8 years ago

PUBLIC SUFFIX LIST domain 'pskov.ru' delisting

Categories

(Core :: Networking: Domain Lists, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla33

People

(Reporter: ma.kuznetsov, Assigned: gerv)

Details

Attachments

(1 file, 1 obsolete file)

Attached patch effective_tld_names.dat.diff (obsolete) — Splinter Review
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.69 Safari/537.36

Steps to reproduce:

We at Information Systems Center of Pskov region (Russia) tried to request wildcard SSL certificate for the 'pskov.ru' domain, but Comodo CA rejecting our request due to Public Suffix List. Domain 'pskov.ru' shouldn't be listed in PSL (as well as other former geographical domains of Russian regions and cities) because it is not have special "geographical" status anymore (since 30.09.2009 - http://cctld.ru/ru/domains/domens_ru/reserved/).

Also please consider possibility of removing all Russian region geographical domains.

Thank you.


Actual results:

'pskov.ru' is on the list


Expected results:

'pskov.ru' shouldn't be on the list
(In reply to Mikhail Kuznetsov from comment #0)
> We at Information Systems Center of Pskov region (Russia) tried to request
> wildcard SSL certificate for the 'pskov.ru' domain, but Comodo CA rejecting
> our request due to Public Suffix List.

They should not have rejected it, at least according to the CAB Forum Baseline Requirements; they should have asked you to prove control over the entire namespace (which presumably you can do).
 
> Domain 'pskov.ru' shouldn't be listed
> in PSL (as well as other former geographical domains of Russian regions and
> cities) because it is not have special "geographical" status anymore (since
> 30.09.2009 - http://cctld.ru/ru/domains/domens_ru/reserved/).

I've translated that page using Google Translate. It doesn't list org.ru, net.ru, com.ru and pp.ru. Are those domains also not special any more, or is that list incomplete?

> Also please consider possibility of removing all Russian region geographical
> domains.

It would be helpful if you could point to a press release or announcement on the official site which mentioned the changes in reserved domains. Wikipedia (which, of course, is not a primary source) still lists them. What happened to all the domains registered underneath them? Or aren't there any?

Gerv
> They should not have rejected it

We think so too, but we are working via reseller, which is even dumber, so it's really difficult to deliver this idea to them.

>It doesn't list org.ru, net.ru, com.ru and pp.ru. Are those domains also not special any more, or is that list incomplete?

The list is complete, 'org.ru', 'net.ru', 'com.ru' and 'pp.ru' are not local geographical domains (in contrast to all other) and they still have special status. I sent you this russian page because it is most authoritative source. Actually there are some domains - http://www.nic.ru/dns/service/en/geo_list.html - which are still in use in obsolete way, despite the fact that they don't have special legal status. So i can't really say should you or should you not to delist all those domains. Maybe you should contact Regional Network Information Center http://www.nic.ru/about/en/contact_ncc.html which is supporting all those former special domains.

Anyway, the 'pskov.ru' domain is in use of Pskov region authorities only and should be delisted for sure.
Attached patch Patch v.2Splinter Review
Assignee: nobody → gerv
Attachment #8414313 - Attachment is obsolete: true
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8437727 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/aeba6fc1fa6b
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
You need to log in before you can comment on or make changes to this bug.