Closed Bug 1003041 Opened 5 years ago Closed 5 years ago

Merge PRenderFrame() and InitRenderFrame() ?

Categories

(Core :: Graphics, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla32

People

(Reporter: smaug, Assigned: smaug)

References

Details

(Keywords: perf)

Attachments

(1 file)

Both PRenderFrame() and InitRenderFrame() are sync messages from child to parent
and based on profiles we end up waiting for the reply from the parent.
So,if we could do just one wait, not two.
It is hard to estimate how much that would help, but we end up waiting for
>10ms waiting for the replies.
Ah, this is a recent regression, from bug 919878
Blocks: 919878
I guess it would be fine to merge them as long as we keep the success parameter. I think I split them up because it seemed weird to have the constructor behave that way. But if it matters for performance, it seems fine.
It seems to be rather important from performance point of view.
Child process is just waiting for quite some time doing nothing.

(But need to think about initialization steps a bit more. I think we should aim
for no sync child-parent messages during normal <iframe mozbrowser> initialization.)
Keywords: perf
Assignee: nobody → bugs
Attachment #8419775 - Flags: review?(wmccloskey)
Attachment #8419775 - Flags: review?(wmccloskey) → review+
Commit message: "Bug 1003041 - Merge PRenderFrame() and InitRenderFrame() to avoid extra sync child->parent messaging, r=billm"
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/edd0cd3d8750
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
You need to log in before you can comment on or make changes to this bug.