Closed Bug 1003117 Opened 8 years ago Closed 8 years ago

verify if the omni.ja size increase due to cld.js and cld.js.mem causes startup performance issues

Categories

(Firefox :: Translation, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: florian, Assigned: Unfocused)

References

Details

(Whiteboard: [translation] p=13 s=it-32c-31a-30b.3 [qa-])

Some concerns were raised about potential startup performance issues due to having a large file shipped in omni.ja, especially:

(Gregory Szorc [:gps] from bug 971047 comment #60)

> Related question: at 1.1 MB, what's the performance impact of having that
> large .mem file in omni.jar? I /think/ we do omni.jar I/O synchronously on
> the main thread. Could there be large jank when this file is first accessed?
> Also, since that file is in omni.jar, we'll get compression on distribution
> for free.
Flags: firefox-backlog?
Flags: firefox-backlog? → firefox-backlog+
Whiteboard: p=0
Component: General → Translation
Whiteboard: p=0 → p=13
Assignee: nobody → bmcbride
Status: NEW → ASSIGNED
Whiteboard: p=13 → p=13 s=it-32c-31a-30b.2 [qa?]
Whiteboard: p=13 s=it-32c-31a-30b.2 [qa?] → p=13 s=it-32c-31a-30b.2 [qa-]
FWIW over in bug 1003118 we've run Talos a number of times and the numbers show no effect from translation on Tpaint.
Whiteboard: p=13 s=it-32c-31a-30b.2 [qa-] → p=13 s=it-32c-31a-30b.3 [qa-]
(In reply to :Felipe Gomes from comment #1)
> FWIW over in bug 1003118 we've run Talos a number of times and the numbers
> show no effect from translation on Tpaint.

Yep, I've been following along. And that backs up with my own investigations.

Tried hard to find a reason *not* to enable translation (in terms of loading cld.js and cld.js.mem), and couldn't come up with any evidence to support that. This summary comes after I've given up trying to find something, because frankly "nothing yet" isn't a particularly useful data point until you get rid of the "yet".


There isn't a whole lot to say when you get no results, but some details:
* No statistically significant differences in Tpaint on Try 
* Ditto for manual Tpaint measurements on a custom Windows7 VM tuned to limit IOPs (mimicking a machine with slow a slow drive)
* No jank caused by loading of cld.js/cld.js.mem during runtime - various profiling sessions showed nothing significantly relevant to this bug (I did see the same issues mentioned in bug 1003118 comment 2)


So, given that, I think we can call this a FIXED in terms of the investigation, and a NOPE in terms of the concern around perf issues caused by shipping cld.js/cld.js.mem.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Marco: Could you add this back to the 32.2 iteration?
Flags: needinfo?(mmucci)
Status: RESOLVED → VERIFIED
Flags: needinfo?(mmucci)
Whiteboard: p=13 s=it-32c-31a-30b.3 [qa-] → [translation] p=13 s=it-32c-31a-30b.3 [qa-]
You need to log in before you can comment on or make changes to this bug.