Closed Bug 1003242 Opened 5 years ago Closed 5 years ago

Exposing mozSettings API to privileged apps

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 846200

People

(Reporter: jj.evelyn, Unassigned)

References

Details

+++ This bug was initially created as a clone of Bug #900551 +++

Right now the homescreen depends on mozSettings to retrieve the user selected background. This makes it hard to write a third party homescreen since mozSettings is for certified apps only.

It would be nice to get rid of this dependency and/or find a way for third party homescreen to access the default background in a pretty way.
see bug 900551 comment 7 to 10. 
This API permission change also involves some implementation change - we should let privileged apps be able to get (or even set) some settings instead of all settings.
Blocks: 900551
No longer depends on: 900551
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 846200
You need to log in before you can comment on or make changes to this bug.