Color at caret (collapsed selection) is not shown correctly on the colorpicker on the toolbar

VERIFIED DUPLICATE of bug 115694

Status

SeaMonkey
Composer
VERIFIED DUPLICATE of bug 115694
17 years ago
13 years ago

People

(Reporter: TucsonTester2, Assigned: Charles Manske)

Tracking

Trunk
mozilla0.9.6

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE)

(Reporter)

Description

17 years ago
Once you choose a different text color other than the default and type a line of
text then hit enter the text color shown by the toolbar reverts to the default
color (i.e. default page settings or the default user settings which are set in
the edit - preferences window).

Reproducibility: everytime

Steps to Reproduce:
1. Open Composer
2. Change the text color using the text color picker on the toolbar
3. Type a word and hit enter (Notice on the new line the color is the default
page setting color)
4. Type some text (notice once you are finished typing the color will update)

Actual Results:
The text color shown by the toolbar does not properly update

Expected Results:
I would expect that the text color on the toolbar would show what the color of
the text would be if I began to type.

Comment 1

17 years ago
*** Bug 100331 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

17 years ago
Forgot to add the build

Build ID: 2001091305

Comment 3

17 years ago
Confirmed on Win2k using build 20010926, and OSX using build 20010924.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago
EDITORBASE
Assignee: syd → cmanske
Whiteboard: EDITORBASE
Target Milestone: --- → mozilla0.9.6
(Assignee)

Comment 5

17 years ago
Who busted this! What i see is this:
After setting the text color using the colorpicke, the color I just 
chose *does* apear in the colorpicker on the toolbar, but as soon as I type, it
changes to the incorrect color!
Status: NEW → ASSIGNED
Summary: Text color does not update on new line until text is typed on the page → Color at caret (collapsed selection) is not shown correctly on the colorpicker on the toolbar
(Assignee)

Comment 6

17 years ago
*** Bug 100408 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

16 years ago
Showing the current color on the toolbar is completely busted, as are all other
inline styles!

*** This bug has been marked as a duplicate of 10690 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
verified.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 9

16 years ago
Reopening to dup to the correct bug
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 10

16 years ago

*** This bug has been marked as a duplicate of 115694 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 11

16 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.