Closed Bug 1003466 Opened 8 years ago Closed 4 years ago

sismologia.cl sends desktop site to Firefox OS

Categories

(Web Compatibility :: Mobile, defect, P5)

All
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: ravmn, Assigned: ravmn)

References

()

Details

(Whiteboard: [mobile-compat-form][country-cl][sitewait] [serversniff])

Site: www.sismologia.cl
sismologia.cl sends desktop site to Firefox OS

:: Steps To Reproduce

1.Load the page on Firefox OS

:: Expected Result

Load mobile version, like in iOS

:: Actual Result

Load desktop version

:: Additional Information

Software Version: 1.1 and 1.3
Device Information: Alcatel OneTouch Fire and Firefox OS simulator
Reporter's User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0
Assignee: nobody → ravmn
Hardware: Other → All
Whiteboard: [mobile-compat-form] → [mobile-compat-form][country-cl][sitewait]
I see the label [sitewait]. Has the site been already contacted?

Note that the redirection goes to an IP address.
http://200.9.100.120/mobile/ for Firefox Android and iOS.

The server is nginx 1.2.3

The detection is not done server side. It's a Web site made of frames. Long time, no see.

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN" "http://www.w3.org/TR/html4/frameset.dtd">
<html>
    <head>
        <!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"><![endif]-->
        <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
        <title>Servicio Sismológico, Universidad de Chile</title>
        <meta name="description" content="Servicio Sismológico, Universidad de Chile">
        <meta name="author" content="SSUCH">
        <!--<meta http-equiv="Pragma" content="no-cache">-->
        <script src="/js/dm.js" type="text/javascript"></script>
        <link rel="stylesheet" href="/css/style.css">
        <!--[if IE 8]> <link rel="stylesheet" href="/css/style_ie8.css"><![endif]-->
    </head>

    <frameset rows="128px,*,35px" frameborder="0" framespacing="0"> 
        <frame name="cabeza" src="links/menu.html" frameborder="0" 
        marginwidth="0" marginheight="0" scrolling="no" noresize="noresize">
        <frame name="centro" src="links/home.html" frameborder="0"
        marginwidth="0" marginheight="0" scrolling="auto" noresize="noresize">
        <frame name="footer" src="links/footer.html" frameborder="0"
        marginwidth="0" marginheight="0" scrolling="no" noresize="noresize">
    </frameset>
</html>

which contains a link to the infamous JS :( for redirection to the mobile version.

(function(a,b){if(/(android|bb\d+|meego).+mobile|avantgo|bada\/|blackberry|blazer|compal|elaine|fennec|hiptop|iemobile|ip(hone|od)|iris|kindle|lge |maemo|midp|mmp|netfront|opera m(ob|in)i|palm( os)?|phone|p(ixi|re)\/|plucker|pocket|psp|series(4|6)0|symbian|treo|up\.(browser|link)|vodafone|wap|windows (ce|phone)|xda|xiino/i.test(a)||/1207|6310|6590|3gso|4thp|50[1-6]i|770s|802s|a wa|abac|ac(er|oo|s\-)|ai(ko|rn)|al(av|ca|co)|amoi|an(ex|ny|yw)|aptu|ar(ch|go)|as(te|us)|attw|au(di|\-m|r |s )|avan|be(ck|ll|nq)|bi(lb|rd)|bl(ac|az)|br(e|v)w|bumb|bw\-(n|u)|c55\/|capi|ccwa|cdm\-|cell|chtm|cldc|cmd\-|co(mp|nd)|craw|da(it|ll|ng)|dbte|dc\-s|devi|dica|dmob|do(c|p)o|ds(12|\-d)|el(49|ai)|em(l2|ul)|er(ic|k0)|esl8|ez([4-7]0|os|wa|ze)|fetc|fly(\-|_)|g1 u|g560|gene|gf\-5|g\-mo|go(\.w|od)|gr(ad|un)|haie|hcit|hd\-(m|p|t)|hei\-|hi(pt|ta)|hp( i|ip)|hs\-c|ht(c(\-| |_|a|g|p|s|t)|tp)|hu(aw|tc)|i\-(20|go|ma)|i230|iac( |\-|\/)|ibro|idea|ig01|ikom|im1k|inno|ipaq|iris|ja(t|v)a|jbro|jemu|jigs|kddi|keji|kgt( |\/)|klon|kpt |kwc\-|kyo(c|k)|le(no|xi)|lg( g|\/(k|l|u)|50|54|\-[a-w])|libw|lynx|m1\-w|m3ga|m50\/|ma(te|ui|xo)|mc(01|21|ca)|m\-cr|me(rc|ri)|mi(o8|oa|ts)|mmef|mo(01|02|bi|de|do|t(\-| |o|v)|zz)|mt(50|p1|v )|mwbp|mywa|n10[0-2]|n20[2-3]|n30(0|2)|n50(0|2|5)|n7(0(0|1)|10)|ne((c|m)\-|on|tf|wf|wg|wt)|nok(6|i)|nzph|o2im|op(ti|wv)|oran|owg1|p800|pan(a|d|t)|pdxg|pg(13|\-([1-8]|c))|phil|pire|pl(ay|uc)|pn\-2|po(ck|rt|se)|prox|psio|pt\-g|qa\-a|qc(07|12|21|32|60|\-[2-7]|i\-)|qtek|r380|r600|raks|rim9|ro(ve|zo)|s55\/|sa(ge|ma|mm|ms|ny|va)|sc(01|h\-|oo|p\-)|sdk\/|se(c(\-|0|1)|47|mc|nd|ri)|sgh\-|shar|sie(\-|m)|sk\-0|sl(45|id)|sm(al|ar|b3|it|t5)|so(ft|ny)|sp(01|h\-|v\-|v )|sy(01|mb)|t2(18|50)|t6(00|10|18)|ta(gt|lk)|tcl\-|tdg\-|tel(i|m)|tim\-|t\-mo|to(pl|sh)|ts(70|m\-|m3|m5)|tx\-9|up(\.b|g1|si)|utst|v400|v750|veri|vi(rg|te)|vk(40|5[0-3]|\-v)|vm40|voda|vulc|vx(52|53|60|61|70|80|81|83|85|98)|w3c(\-| )|webc|whit|wi(g |nc|nw)|wmlb|wonu|x700|yas\-|your|zeto|zte\-/i.test(a.substr(0,4)))window.location=b})(navigator.userAgent||navigator.vendor||window.opera,'http://200.9.100.120/mobile/');
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(ravmn)
Whiteboard: [mobile-compat-form][country-cl][sitewait] → [mobile-compat-form][country-cl][sitewait] [serversniff]
Yes, tried to contact them 2 times (about a month ago and 2 days ago). I will try to go to their building soon.
Flags: needinfo?(ravmn)
I could go to the building because I had no time. Just sended an e-mail to the technical contact from  http://nic.cl/registry/Whois.do?d=bancochile.cl
Priority: -- → P5
No longer necessary
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.