Closed Bug 1003652 Opened 7 years ago Closed 7 years ago

Always turn on ril debugging in telephony marionette test

Categories

(Firefox OS Graveyard :: RIL, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(feature-b2g:2.0, tracking-b2g:backlog)

RESOLVED FIXED
2.0 S2 (23may)
feature-b2g 2.0
tracking-b2g backlog

People

(Reporter: aknow, Assigned: aknow)

References

Details

(Whiteboard: [p=1])

Attachments

(1 file, 1 obsolete file)

Recently, we encounter several time out in telephony marionette tests executed on try server. However, it's difficult to dig into the problem without the ril debugging log. So I would like to always turn on the debugging in those test cases.

Will it cause any problem?
Achieve by altering the pref value during tests.
Attachment #8414980 - Flags: review?(htsai)
Comment on attachment 8414980 [details] [diff] [review]
Turn on debugging in marionette test

Review of attachment 8414980 [details] [diff] [review]:
-----------------------------------------------------------------

I think Jonathan is a properer reviewer.
Attachment #8414980 - Flags: review?(htsai) → review?(jgriffin)
(In reply to Hsin-Yi Tsai  [:hsinyi] from comment #2)
> Comment on attachment 8414980 [details] [diff] [review]
> Turn on debugging in marionette test
> 
> Review of attachment 8414980 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> I think Jonathan is a properer reviewer.

... ?
The modification is done in telephony's head.js
(In reply to Szu-Yu Chen [:aknow] from comment #3)
> (In reply to Hsin-Yi Tsai  [:hsinyi] from comment #2)
> > Comment on attachment 8414980 [details] [diff] [review]
> > Turn on debugging in marionette test
> > 
> > Review of attachment 8414980 [details] [diff] [review]:
> > -----------------------------------------------------------------
> > 
> > I think Jonathan is a properer reviewer.
> 
> ... ?
> The modification is done in telephony's head.js

Aknow, sorry for not explaining myself. The change itself is fine for me, but I am not sure how it would afect the whole marrionet process. Vicamo told me that marionette process has been killed due to a large logging message. Is the situation still? This pref not only works for TelephonyProvider module but also for ril_worker, rilcontenthelper , data connection ... the message size is obvious. That's why I think I would like to have Jonathan's review. The other thing is turning on debugging might longer the test time. We shall be more careful to not lead to more timeout possibilities. Thank you.
According to timeout, we could solve it by splitting the cases or extand the time, so not that serious. Just to make sure we have enough tests on try before landing.
Comment on attachment 8414980 [details] [diff] [review]
Turn on debugging in marionette test

Review of attachment 8414980 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me, but I still like to see if Jonathan is okay with this (see comment 4), thanks.
Attachment #8414980 - Flags: review+
(In reply to Hsin-Yi Tsai  [:hsinyi] from comment #5)
> According to timeout, we could solve it by splitting the cases or extand the
> time, so not that serious. Just to make sure we have enough tests on try
> before landing.

It's time out, but not means the running time is not enough.

What I found is that some events are missing and it cause our test script stuck at somewhere. We can not dig into the problem without the log. All we can do is to enable the log and retest it on the try server. It wastes the time and is not guaranteed reproducible.
(In reply to Szu-Yu Chen [:aknow] from comment #7)
> (In reply to Hsin-Yi Tsai  [:hsinyi] from comment #5)
> > According to timeout, we could solve it by splitting the cases or extand the
> > time, so not that serious. Just to make sure we have enough tests on try
> > before landing.
> 
> It's time out, but not means the running time is not enough.
> 
> What I found is that some events are missing and it cause our test script
> stuck at somewhere. We can not dig into the problem without the log. All we
> can do is to enable the log and retest it on the try server. It wastes the
> time and is not guaranteed reproducible.

Totally agree!
Comment on attachment 8414980 [details] [diff] [review]
Turn on debugging in marionette test

Review of attachment 8414980 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm; I don't think this should cause any problems for our test infrastructure
Attachment #8414980 - Flags: review?(jgriffin) → review+
Whiteboard: [p=1]
Target Milestone: --- → 2.0 S2 (23may)
See Also: → 1003650
https://hg.mozilla.org/mozilla-central/rev/219cb1047f3b
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
blocking-b2g: --- → backlog
feature-b2g: --- → 2.0
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.