Banking applet - entry page doesn't even display properly

RESOLVED INVALID

Status

Core Graveyard
Java: OJI
RESOLVED INVALID
17 years ago
7 years ago

People

(Reporter: Simon Redding, Assigned: Sergi)

Tracking

({ecommerce})

Trunk
x86
Windows 2000
ecommerce

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Java1, URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)
BuildID:    2001091303

This banking applet works fine under IE5.5SP1, but really screws up under 
Mozilla (0.9.4).  Sorry I'm using IE to report this - it just happened to be 
running )^;
The resources file doesn't appear to load; could this be a Blackwood problem?


Reproducible: Always
Steps to Reproduce:
1. Load the page above.  Wait until the applet loads
2. Compare the display between IE5 and Moz 0.9.4 - wildly different...
3. Mmmm

Expected Results:  Displayed the applet properly

I didn't write this applet I'm afraid - it was entranet.co.uk

Comment 1

17 years ago
confirming on Win2k with build 2001091803, graphics and layout are fine, exactly
the same as with IE6 but the text doesn't show, only 'unknown text id'.

Comment 2

17 years ago
Created attachment 49822 [details]
Screenshot of Mozilla displaying the applet

Comment 3

17 years ago
wfm with build 2001091421 on Linux.

I forgot to note in my previous comment that the 'demo' (clicking on the right
button to launch demo) works fine under Win2k: clicking on buttons works, it's
just the text that is not displayed properly.

Comment 4

17 years ago
moving to oji
Assignee: idk → edburns
Component: Java-Implemented Plugins → OJI
This comment may be useless, but it works fine under Linux.
BuildID 2001090721
JavaPlugin: Java(TM) Plug-in Blackdown-1.3.1-FCS

Comment 6

16 years ago
Reassign to Joe as I'm leaving the role of OJI module owner.
Status: UNCONFIRMED → NEW
QA Contact: avm → pmac
Target Milestone: --- → mozilla0.9.5

Comment 7

16 years ago
Ressign to Joe Chou, as I am no longer working officially on OJI.
Assignee: edburns → joe.chou
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Comment 8

16 years ago
Re-assign to sep.
Assignee: joe.chou → sep
Status: NEW → UNCONFIRMED
Target Milestone: mozilla0.9.6 → mozilla0.9.9

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

16 years ago
I tried to look at mentioned URL (current mozilla trunk Mozilla/5.0 (Windows; 
U; Windows NT 5.0; en-US; rv:0.9.6+) Gecko/20011207)
but I encountered problems related to opening https connection to the the.co-
operativebank.co.uk.

I downloaded the coop.html and other related pages and changed applet codebase 
from https to the http protocol. The applet loads ok and looks the same as in 
other browsers (I tried also IE 5.0 and Netscape 4.76)

To reporter:
Is this bug reprodusible on the latest mozilla builds?
What version of JRE did you use?

Updated

15 years ago
QA Contact: pmac → petersen

Comment 10

15 years ago
*** Bug 146737 has been marked as a duplicate of this bug. ***
Target Milestone: mozilla0.9.9 → ---

Comment 11

15 years ago
Works for me with java 1.3.1 see http://bugzilla.mozilla.org/show_bug.cgi?
id=182026

Comment 12

15 years ago
-- Verified on latest trunk on Win2K with JRE1.4.2_Beta. Applet throws up the
below exceptions

javax.net.ssl.SSLException: SSL V2.0 servers are not supported.
at com.sun.net.ssl.internal.ssl.InputRecord.b(Unknown Source)
at com.sun.net.ssl.internal.ssl.InputRecord.read(Unknown Source)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.a(Unknown Source)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.j(Unknown Source)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHandshake(Unknown Source)
at sun.net.www.protocol.https.HttpsClient.afterConnect(Unknown Source)
at
sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.setNewClient(Unknown
Source)
at
sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.superConnect(Unknown
Source)
at
sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.access$000(Unknown
Source)
at sun.net.www.protocol.https.PluginDelegateHttpsURLConnection$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.connect(Unknown
Source)
at
sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.getInputStream(Unknown
Source)
at java.net.HttpURLConnection.getResponseCode(Unknown Source)
at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(Unknown Source)
at sun.plugin.cache.CachedFileLoader.load(Unknown Source)
at sun.plugin.cache.FileCache.get(Unknown Source)
at
sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.connectWithCache(Unknown
Source)
at sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.connect(Unknown
Source)
at
sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.getInputStream(Unknown
Source)
at java.net.HttpURLConnection.getResponseCode(Unknown Source)
at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(Unknown Source)
at sun.applet.AppletClassLoader.getBytes(Unknown Source)
at sun.applet.AppletClassLoader.access$100(Unknown Source)
at sun.applet.AppletClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at sun.applet.AppletClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.applet.AppletClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.applet.AppletClassLoader.loadCode(Unknown Source)
at sun.applet.AppletPanel.createApplet(Unknown Source)
at sun.plugin.AppletViewer.createApplet(Unknown Source)
at sun.applet.AppletPanel.runLoader(Unknown Source)
at sun.applet.AppletPanel.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Need traction on this bug.
Whiteboard: Java1

Updated

14 years ago
Keywords: ecommerce

Comment 13

14 years ago
This bug is no longer valid as the web site doesn't use java now to access
banking details.

Status should be changed to INVALID

Comment 14

14 years ago
The comment above is incorrect as of right now as I'm checking -- the URL listed
above still has a Java applet, and it still fails to load on Firebird 0.7, Java
1.4.2_01, Linux 2.4.20 (RedHat 9).

There was a relevant discussion quite some time ago on a Sun Java forum:

http://forum.java.sun.com/thread.jsp?thread=4257&forum=2&message=697848

Can I hazard a guess that the problem not appearing with IE was due to IE using
the MS VM?

There is an apparent work-around on the Java-coder end at:

http://forum.java.sun.com/thread.jsp?forum=2&thread=423485

I suspect that this is a Java envangelism issue, and as such this bug is INVALID
in the context of being a Mozilla bug.

-M
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 15

14 years ago
That page still exists, but is no longer the co-op's on-line banking page. They
now use a simly SSL encrypted web page.

Comment 16

14 years ago
Thanks Hugh 

that's what I should have said

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.