Closed Bug 1003817 Opened 6 years ago Closed 6 years ago

[BB] Buttons: update list button to new specs

Categories

(Firefox OS Graveyard :: Gaia, defect)

x86
macOS
defect
Not set

Tracking

(b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S1 (9may)
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: arnau, Assigned: paco)

References

Details

Attachments

(3 files)

As discussed in https://bugzilla.mozilla.org/show_bug.cgi?id=995124#c14 List button with arrow should look more like a list item than a button.
Assignee: nobody → arnau
Blocks: 995124
Attached image button.png
Przemek, could you please provide specs for list button with arrow?
If we remove italic style, will look like this.
Font for buttons is 17px while for labels is 19px.
Flags: needinfo?(pabratowski)
For what it's worth, I think the font size should be the same in regular list items and in list "buttons" with arrows (they are not really buttons anymore, but sub-menu items).

Also, I believe a spec for the new Settings UX is already being worked on by Omega in bug 995124. The list button there already looks not-italic and has the same font-size as other non-button items.
(In reply to Jan Keromnes [:janx] from comment #2)
> Also, I believe a spec for the new Settings UX is already being worked on by
> Omega in bug 995124. The list button there already looks not-italic and has
> the same font-size as other non-button items.

The one I provided is just UX spec. It's better to have a visual spec. Przemek can do that. :)
The font should be exactly the same for this list item with an arrow as a list item without an arrow. I agree this is no longer a button. I'm working on a more detailed visual spec today and will attach it shortly.
Attached image nav_btn_2.0_page.jpg
Ok, I had a meeting with Arnau this morning and this is the direction. 

1. The main settings page should use the ">" arrows.
2. The rest of the list items with arrows will once again use a button shape. The exact same button as the value selector buttons. This was done because removing the button shape for the arrow buttons created a lot of problems for situations where this button was used with a label. 

We have a more complete design solution that will require more time to implement for these buttons but these changes will come in a future releases (2.1 +).

Please take a look at the attached design spec.
Flags: needinfo?(pabratowski)
Assignee: arnau → pacorampas
Thanks for the visual spec Przemek! I really liked the direction bug 969484 was taking by making sub-menu links not look like buttons anymore, but I understand that this might cause problems e.g. when used with a label.
Attached file Patch in github
Attachment #8418582 - Flags: review?(arnau)
Comment on attachment 8418582 [details] [review]
Patch in github

Awesome, thanks Paco :)
Attachment #8418582 - Flags: review?(arnau) → review+
Merged: 9d1352a320ab29c8979f2add173e59433963e46a
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S1 (9may)
Guys, your pull request regressed assets size on hidpi devices like the Flame.
Yes, you are right. We forgot a background-size :(
I'll file a new bug to follow up.
Alexandre,
Paco has fixed the regression.
Could you please verify it?
Thanks!
Flags: needinfo?(lissyx+mozillians)
Yes, I can confirm it is fixed by this followup.
Flags: needinfo?(lissyx+mozillians)
Are we landing this, or is it landed?
Stephany, is already landed:

Merged: 9d1352a320ab29c8979f2add173e59433963e46a

Status: NEW → RESOLVED
Resolution: --- → FIXED
Last Resolved: 2014-05-07 01:53:42
You need to log in before you can comment on or make changes to this bug.