Closed Bug 1003839 Opened 6 years ago Closed 6 years ago

Live bookmark is still created despite cancelling the subscription

Categories

(Firefox :: Bookmarks & History, defect)

30 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 32
Tracking Status
firefox29 --- unaffected
firefox30 + verified
firefox31 + verified
firefox32 + verified

People

(Reporter: avaida, Assigned: mano)

References

Details

(Keywords: regression, Whiteboard: p=5 s=it-32c-31a-30b.2 [qa!])

Attachments

(1 file)

Reproducible on:
 * Windows 7 64-bit [1],
 * Mac OS X 10.8 [2], 
 * Ubuntu 14.04 LTS 32-bit [3],
using Firefox 30 Beta 1 (Build ID: 20140428174145), Aurora 31.0a2 (2014-04-30) and Nightly 32.0a1 (2014-04-30)

Steps to reproduce:
1. Launch Firefox
2. Enable the bookmarks toolbar.
3. Access the following URL: https://blog.mozilla.org/feed/
4. Press the "Subscribe" button then choose "Cancel".

Expected result:
The subscription to that specific website is cancelled.

Actual result:
The subscription is made despite being cancelled and a live bookmark is added to the bookmarks toolbar.

This is a recent regression, window below:
(m-c)
* last good: 44ae8462d6ab
* first bad: 46041cc216fd
* pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=44ae8462d6ab&tochange=46041cc216fd 
 
(m-i)
* last good: a9182238dc0b
* first bad: ad954f1cf3db
* pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a9182238dc0b&tochange=ad954f1cf3db

This is as far as I got without building locally. 

I suspect it might have been caused by:
c1651a5658df Asaf Romano — Bug 891303 - New Places Async Transaction manager (backend part. affects nothing for now). r=mak. sr=gavin
* https://hg.mozilla.org/integration/mozilla-inbound/rev/c1651a5658df


1. Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
2. Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:30.0) Gecko/20100101 Firefox/30.0
3. Mozilla/5.0 (X11; Linux i686; rv:30.0) Gecko/20100101 Firefox/30.0
is this reproducible on Firefox 31?

I wonder if this is just due to the missing fix of bug 984015 in Firefox 30
Blocks: 891303
Flags: firefox-backlog?
(In reply to Marco Bonardo [:mak] from comment #1)
> is this reproducible on Firefox 31?
> 
> I wonder if this is just due to the missing fix of bug 984015 in Firefox 30
I was able to reproduce the bug on Nightly 31.0a1 (Build ID: 20140427030204) from 2014-04-27 as well and, it is also reproducible on Aurora 31.0a2 (2014-04-30), as I previously mentioned in Comment 0.
Is this also affected on new nightlies (32)?  We should definitely fix this regression and never ship it.
(In reply to Lukas Blakk [:lsblakk] from comment #3)
> Is this also affected on new nightlies (32)?  We should definitely fix this
> regression and never ship it.

very likely, I don't know of a fix touching that code after 31.
Flags: firefox-backlog? → firefox-backlog+
(In reply to Marco Bonardo [:mak] from comment #4)
> (In reply to Lukas Blakk [:lsblakk] from comment #3)
> > Is this also affected on new nightlies (32)?  We should definitely fix this
> > regression and never ship it.
> 
> very likely, I don't know of a fix touching that code after 31.

I can confirm that this bug also affects Nightly 32.0a1 (2014-05-01).
Whiteboard: p=5
Assignee: nobody → mano
Status: NEW → ASSIGNED
Whiteboard: p=5 → p=5 s=it-32c-31a-30b.2 [qa?]
Whiteboard: p=5 s=it-32c-31a-30b.2 [qa?] → p=5 s=it-32c-31a-30b.2 [qa+]
Attached patch patchSplinter Review
When the callback-api was used, we just didn't check the status, which was not always a failure.

I don't think this is worth a test given that this code is on its way out and that this transaction is not tested at all.
Attachment #8424985 - Flags: review?(mak77)
I must correct the regressing bug, according to the patch it's Bug 969318. The regression range is still correct.
Blocks: 969318
No longer blocks: 891303
Attachment #8424985 - Flags: review?(mak77) → review+
https://hg.mozilla.org/mozilla-central/rev/8d51c866de2c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Comment on attachment 8424985 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 969318
User impact if declined: livemark created despite canceling the action
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): low risk (restoring previous behavior)
String or IDL/UUID changes made by this patch: none
Attachment #8424985 - Flags: approval-mozilla-beta?
Attachment #8424985 - Flags: approval-mozilla-aurora?
QA Contact: camelia.badau
Attachment #8424985 - Flags: approval-mozilla-beta?
Attachment #8424985 - Flags: approval-mozilla-beta+
Attachment #8424985 - Flags: approval-mozilla-aurora?
Attachment #8424985 - Flags: approval-mozilla-aurora+
Verified fixed on Windows 7 64bit, 32bit, Ubuntu 13.10 32bit and Mac OSX 10.8.5 using latest Nightly 32.0a1 (buildID: 20140522030204). 

I will change the Status flag as soon as I'll verify this fix on Aurora and Beta.
Verified fixed on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.8.5 using: 
- latest Aurora 31.0a2 (build ID: 20140523004002)
- Firefox 30 Beta 7 (buildID: 20140522105902).
Status: RESOLVED → VERIFIED
Whiteboard: p=5 s=it-32c-31a-30b.2 [qa+] → p=5 s=it-32c-31a-30b.2 [qa!]
You need to log in before you can comment on or make changes to this bug.