Closed Bug 1003919 Opened 10 years ago Closed 10 years ago

Need 'Not Rated' Category for all Marketplace Apps

Categories

(Marketplace Graveyard :: Consumer Pages, defect, P1)

2014-Q2
ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

VERIFIED FIXED
2014-06-17

People

(Reporter: kward, Assigned: robhudson)

Details

(Whiteboard: [see comment 11])

Attachments

(3 files)

As I think everyone knows, it has proven challenging to get all developers to rate their apps using the IARC tool even though many teams have put a great deal of effort into communicating the benefits of doing so.  

In an effort to avoid 'de-listing' un-rated apps, we need to modify Marketplace to display: 'No age rating available' unless and ESRB rating is linked to the app.
In addition apps that do not have an ESRB rating should not be displayed to users in any region that has an age rating restriction (i.e. Brazil, Germany).

I am adding two screen shots: One of an ESRB and end-user rated app and one of an app that does not have an End-User or ESRB rating.  You will note that page displayed to Marketplace users in the 2nd scenario is a bit confusing.  Is it possible to provide better clarity between the 2 ratings when this modification is implemented?
Flags: needinfo?(dbialer)
Flags: needinfo?(asantos)
It seems we need to add, as you suggest "No age rating available" under the dev name.
Flags: needinfo?(dbialer)
Attachment 8415377 [details] displays the phrase "not yet rated".  I'm attaching another screenshot for unrated apps that don't have this descriptor.  I actually thought all the unrated apps were in the second category, and didn't realize that some apps say "not yet rated".

The user story is that users should be informed that an app isn't rated.  I don't have a preference between: (1) "not yet rated" (2) "unrated" (3) "not rated" (4) "no age rating".  You can select what you think is best.

Thanks,
Mika
What is being displayed in the 2nd screenshot Karen provided is not a content rating, it's a star rating (a "quality rating" for a sake of a better term to differentiate the two.) In adding a "no content rating provided" category we could simply keep the labeling scheme showed, so an app that had no content rating would say "ESRB: not yet rated" or "PEGI: not yet rated", etc following the pattern we use today. This would bring some clarity to the two ratings and I believe the label + the proximity of the "not yet rated" to the empty star ratings indicator would  clarify the two different types of ratings.
Flags: needinfo?(asantos)
For trademark reasons, we can't use ESRB, PEGI, etc. Can we say: 
- "Not yet rated" (or "age rating unavailable") for the app rating and 
- "Not yet reviewed" for the user review rating?
I'm sure I can write something that get's us that effect. Do we have guidelines about how we can and cannot use the various ratings system's names in print?
(In reply to Tony Santos [:tsmuse] from comment #7)
> I'm sure I can write something that get's us that effect. Do we have
> guidelines about how we can and cannot use the various ratings system's
> names in print?

If we use the names of the rating systems, they will want to review in advance how it's used.  If you can write something up to the effect of age ratings unavailable and no user reviews, without reference to the rating systems, I think that would be best :)
Assignee: nobody → asantos
Please provide an update on this bug.  We need it completed.
Flags: needinfo?(asantos)
It sounds like we can't do much more than "Not yet rated" and "Not yet reviewed" without triggering a review of the strings by the partners. If we're unwilling to do that, I'd say just go with those two above strings. We're not going to get any more specific or helpful than that without specifying the local rating system the app is not rated in to put the non-rating in the same context as the ratings.
Flags: needinfo?(asantos)
Assignee: asantos → nobody
Ok, this bug is to:

1) Replace "Not yet rated" string next to star ratings with "Not yet reviewed"

2) Add a "Not yet rated" option to the official ratings area (eg. the line where it says "PEGI: 18+")

3) Ensure any unrated apps are not shown in Germany and Brazil.  I think this used to be only Games but let's just make it all apps if it's simpler

4) I didn't find any messaging about the ratings and being disabled (I think we used to have some in a title tag).  If there is any, let's get rid of it though.
Whiteboard: [see comment 11]
No longer depends on: 930846
Mika - please confirm Wil's comment 11 as either correct or advise how to change it.
Flags: needinfo?(udevi)
Wil's comment 11 is correct.
Flags: needinfo?(udevi)
Priority: P2 → P1
Assignee: nobody → robhudson.mozbugs
https://github.com/mozilla/fireplace/commit/c586bde 
https://github.com/mozilla/zamboni/commit/7bf857f
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2014-06-17
Verified in marketplace-dev on FF33 (Win7)
The Not yet rated string is displayed under the author and the Not yet reviewed for apps without reviews.
The problem is that those apps are also displayed in both Germany and Brazil.
Please view this screencast: http://screencast.com/t/QBI9s0JP0

Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Madalin Cotetiu from comment #15)
> The problem is that those apps are also displayed in both Germany and Brazil.
> Please view this screencast: http://screencast.com/t/QBI9s0JP0

Follow up commit to reindex the apps we flag as unrated in BR and DE:
https://github.com/mozilla/zamboni/commit/8bf4aea 

Unrated apps are no longer listed in search results and listing pages for BR/DE.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Verified as fixed in marketplace-dev on FF33 (Win7). Unrated apps are no longer displayed in Brazil and Germany. 
Postfix screencast: http://screencast.com/t/wIpIKMhcnD7
Closing.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: