Closed Bug 1004097 Opened 6 years ago Closed 6 years ago

Intermittent browser_net_json_custom_mime.js | Test timed out | Found a tab after previous test timed out: http://example.com/browser/browser/devtools/netmonitor/test/html_json-custom-mime-test-page.html

Categories

(DevTools :: Netmonitor, defect)

26 Branch
x86_64
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 872379

People

(Reporter: RyanVM, Unassigned)

Details

(Keywords: intermittent-failure)

https://tbpl.mozilla.org/php/getParsedLog.php?id=38824500&tree=Mozilla-Inbound

Rev5 MacOSX Mountain Lion 10.8 mozilla-inbound opt test mochitest-devtools-chrome on 2014-04-30 12:13:56 PDT for push 00edef0582f1
slave: talos-mtnlion-r5-006

12:24:28     INFO -  TEST-START | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js
12:24:28     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | Initializing a network monitor pane.
12:24:28     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | Adding tab: http://example.com/browser/browser/devtools/netmonitor/test/html_json-custom-mime-test-page.html
12:24:28     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | Net tab added successfully: http://example.com/browser/browser/devtools/netmonitor/test/html_json-custom-mime-test-page.html
12:24:28     INFO -  1398885868471	Browser.Experiments.Experiments	TRACE	Experiments #0::updateManifest()
12:24:28     INFO -  1398885868471	Browser.Experiments.Experiments	TRACE	Experiments #0::_run
12:24:28     INFO -  1398885868472	Browser.Experiments.Experiments	TRACE	Experiments #0::_main iteration
12:24:28     INFO -  1398885868472	Browser.Experiments.Experiments	TRACE	Experiments #0::_loadManifest
12:24:28     INFO -  1398885868473	Browser.Experiments.Experiments	TRACE	Experiments #0::httpGetRequest(http://127.0.0.1:8888/experiments-dummy/manifest)
12:24:28     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | Netork monitor pane shown successfully.
12:24:28     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | Starting test...
12:24:28     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | Console message: 1398885868471	Browser.Experiments.Experiments	TRACE	Experiments #0::updateManifest()
12:24:28     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | Console message: 1398885868471	Browser.Experiments.Experiments	TRACE	Experiments #0::_run
12:24:28     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | Console message: 1398885868472	Browser.Experiments.Experiments	TRACE	Experiments #0::_main iteration
12:24:28     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | Console message: 1398885868472	Browser.Experiments.Experiments	TRACE	Experiments #0::_loadManifest
12:24:28     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | Console message: 1398885868473	Browser.Experiments.Experiments	TRACE	Experiments #0::httpGetRequest(http://127.0.0.1:8888/experiments-dummy/manifest)
12:24:28     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | > Network events progress: 1/13, 0/0
12:24:28     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | > Network events progress: 2/13, 0/0
12:24:28     INFO -  1398885868515	Browser.Experiments.Experiments	ERROR	Experiments #0::httpGetRequest::onLoad() - Request to http://127.0.0.1:8888/experiments-dummy/manifest returned status 404
12:24:28     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | Console message: [JavaScript Error: "1398885868515	Browser.Experiments.Experiments	ERROR	Experiments #0::httpGetRequest::onLoad() - Request to http://127.0.0.1:8888/experiments-dummy/manifest returned status 404" {file: "resource://gre/modules/Log.jsm" line: 760}]
12:24:28     INFO -  1398885868515	Browser.Experiments.Experiments	ERROR	Experiments #0::_loadManifest - failure to fetch/parse manifest (continuing anyway): Error: Experiments - XHR status for http://127.0.0.1:8888/experiments-dummy/manifest is 404
12:24:28     INFO -  1398885868516	Browser.Experiments.Experiments	TRACE	Experiments #0::_evaluateExperiments
12:24:28     INFO -  1398885868517	Browser.Experiments.Experiments	TRACE	Experiments #0::_main finished, scheduling next run
12:24:28     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | > Network events progress: 3/13, 0/0
12:24:28     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | Console message: [JavaScript Error: "1398885868515	Browser.Experiments.Experiments	ERROR	Experiments #0::_loadManifest - failure to fetch/parse manifest (continuing anyway): Error: Experiments - XHR status for http://127.0.0.1:8888/experiments-dummy/manifest is 404" {file: "resource://gre/modules/Log.jsm" line: 760}]
12:24:28     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | Console message: 1398885868516	Browser.Experiments.Experiments	TRACE	Experiments #0::_evaluateExperiments
12:24:28     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | Console message: 1398885868517	Browser.Experiments.Experiments	TRACE	Experiments #0::_main finished, scheduling next run
12:24:28     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | > Network events progress: 4/13, 0/0
12:25:13     INFO -  libpng warning: zero length keyword
12:25:13     INFO -  libpng warning: Empty language field in iTXt chunk
12:25:13     INFO -  TEST-INFO | screencapture: exit 0
12:25:13  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | Test timed out
12:25:13     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | finish() was called, cleaning up...
12:25:13     INFO -  TEST-INFO | MEMORY STAT vsize after test: 4018647040
12:25:13     INFO -  TEST-INFO | MEMORY STAT residentFast after test: 928698368
12:25:13     INFO -  TEST-INFO | MEMORY STAT heapAllocated after test: 152296248
12:25:13     INFO -  INFO TEST-END | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | finished in 45035ms
12:25:13  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_custom_mime.js | Found a tab after previous test timed out: http://example.com/browser/browser/devtools/netmonitor/test/html_json-custom-mime-test-page.html
12:25:13     INFO -  TEST-INFO | checking window state
12:25:13     INFO -  TEST-START | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_json_text_mime.js
Has not occurred since fix for bug 872379 landed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 872379
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.