Closed Bug 1004183 Opened 6 years ago Closed 6 years ago

dom/media/MediaManager.cpp:1343:7: error: 'c' was not declared in this scope (--disable-webrtc)

Categories

(Core :: WebRTC, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla32
Tracking Status
firefox31 --- fixed
firefox32 --- fixed

People

(Reporter: jbeich, Assigned: jbeich)

References

Details

(Whiteboard: [qa-] )

Attachments

(1 file)

Attached patch fixSplinter Review
Sparc, MIPS, AArch64, etc. and Solaris still default to --disable-webrtc. OpenBSD downstream also doesn't want WebRTC until PulseAudio dependency is excised (bug 911450 or bug 952828 comment 14).

In file included from dom/media/Unified_cpp_dom_media0.cpp:15:
dom/media/MediaManager.cpp:1343:7: error: use of undeclared identifier 'c'
  if (c.mPicture && !aPrivileged) {
      ^
1 error generated.

http://buildbot.rhaalovely.net/builders/comm-central-amd64/builds/1079/steps/build/logs/stdio
http://buildbot.rhaalovely.net/builders/mozilla-central-sparc64/builds/785/steps/build/logs/stdio
Attachment #8415585 - Flags: review?(jib)
Comment on attachment 8415585 [details] [diff] [review]
fix

Review of attachment 8415585 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8415585 - Flags: review?(jib) → review+
https://hg.mozilla.org/mozilla-central/rev/6e5eb6a1b0a8
Assignee: nobody → jbeich
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8415585 [details] [diff] [review]
fix

http://buildbot.rhaalovely.net/builders/mozilla-aurora-sparc64/builds/415

I think this needs to land on aurora/31, since this still fails for me.

[

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 907352
User impact if declined: failure to build aurora with disable-webrtc
Testing completed (on m-c, etc.): yes
Risk to taking this patch (and alternatives if risky): yolo!
String or IDL/UUID changes made by this patch: none
Attachment #8415585 - Flags: approval-mozilla-aurora?
I'll note for the drivers that --disable-webrtc is NPOTB (at least before the Tarako; fabrice wants to use it there).  There should be no risk taking this on Aurora; if it builds after landing all is good.
Attachment #8415585 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/2ee9cf2caf42
m-a builds fine with this, 1004194 and 981780 (still using --disable-webrtc)
jib, is this something that would need testing by QA or to be in the testsuite? Thanks!
Flags: needinfo?(jib)
Whiteboard: [qa?]
If by 'this' you mean this particular patch, then no. I think if it builds it should be fine.

If you're asking would it be useful if the test suite could catch these kinds of bugs, then yes, say a new target (perhaps excluded by default) with --disable-webrtc.
Flags: needinfo?(jib)
Flags: in-qa-testsuite?(hskupin)
Whiteboard: [qa?] → [qa-]
I do not see a reason why this should be covered by a QA owned test framework. Not sure if that would even be doable.
Flags: in-testsuite?
Flags: in-qa-testsuite?(hskupin)
Flags: in-qa-testsuite-
You need to log in before you can comment on or make changes to this bug.