Closed Bug 1004239 Opened 8 years ago Closed 8 years ago

[B2G][1.4][l10n][Messaging]: The string "The page at app://sms.gaiamobile.org says:" is not translated when you attempt to attach a large file

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, b2g-v1.3 unaffected, b2g-v1.4 verified, b2g-v2.0 fixed)

VERIFIED FIXED
2.0 S1 (9may)
blocking-b2g 1.4+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.4 --- verified
b2g-v2.0 --- fixed

People

(Reporter: mlivingston, Assigned: aus)

References

Details

(Keywords: regression, Whiteboard: [systemsfe][p=1] LocRun1.4)

Attachments

(3 files)

Attached image sms.gaiamobile.org
Description:
When composing a new message in the Messages app, and then attaching a file that is too large, the following string will appear: "The page at app://sms.gaiamobile.org says:". It appears as a 'header' above "The file you have selected is too large."

This seems to be a hardcoded issue and was checked in: Lithuanian, English, French, and Galician.

Repro Steps:
1) Update a Buri to BuildID: 20140430000201
2) From the home screen, select the "Messages" app. 
3) Tap on the "Compose" icon to compose a new message in the upper right hand corner.
4) Tap the "paperclip" icon.
5) Attach a file that is very large.
6) Observe the string "The page at app://sms.gaiamobile.org says:" in the header.

Actual:
The string "The page at app://sms.gaiamobile.org says:" appears as the header.

Expected:
The string "The page at app://sms.gaiamobile.org says:" should not appear.

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140430000201
Gaia: 81e97c3ca58be0487292011bc59efa4cebab30be
Gecko: 123485e733d5
Version: 30.0
Firmware Version: v1.2-device.cfg

Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/12138/
See attached: Screenshot
1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140425024003
Gaia: 32a9e3db738e0b3bc44a4d4d5c16512a2617a2cf
Gecko: c96b0cf6343f
Version: 28.0
Firmware Version: v1.2-device.cfg

The string 'The page at app://sms.gaiamobile.org say:' does not exist on the Buri 1.3 MOZ RIL.
Was this working on a 4/28 1.4 build?
Component: General → Gaia::System::Window Mgmt
Keywords: qawanted
Attached image 4-28 1.4 (no issue)
(In reply to Jason Smith [:jsmith] from comment #2)
> Was this working on a 4/28 1.4 build?

Confirmed that issue does NOT reproduce on 4/28 1.4 Aurora. Attaching a screenshot in English.

Tested on:
Device: Buri 1.4 MOZ
BuildID: 20140428000206
Gaia: d23e479e8a4ce0bc620acb2d7e2f82801aa4d0ea
Gecko: 36f67ce46855
Version: 30.0a2
Firmware Version: v1.2-device.cfg
I'm pretty sure this was caused by bug 999511.

Aus - Can you take a look?
Blocks: 999511
blocking-b2g: --- → 1.4?
Flags: needinfo?(aus)
Yup, that's probably my fault. Fix one thing, regress another. So frustrating. :) Anyway, I think I have the magic combination of filters now to fix this for good.
Status: NEW → ASSIGNED
Flags: needinfo?(aus)
Whiteboard: LocRun1.4 → [systemsfe][p=1] LocRun1.4
Target Milestone: --- → 2.0 S1 (9may)
Assignee: nobody → aus
This WFM on Gecko32/Gaia2...
There's a bug in 1.4 with AppWindow's and their associated context (specifically talking about the URL) with launching Activities. Activities will make Modals think they are being triggered by the App who's activity was last active instead of the application that launched the activity.

This works as expected on master, and that's why the issue doesn't exist there.

I'm now filtering out all titles with the "app://" protocol present and replacing it with the name of the application.

This stuff already has unit tests for it, so I'm going to go ahead and commit this. I've tested the fix on a Flame (v1.4/v2.0) and on a Peak (v1.4/v2.0) and against the STRs in bug 999511 as well.
Comment on attachment 8416110 [details] [review]
Pull Request - Filter out all titles with 'app://' protocol in them and replace with application name when available (or empty string when not)

I promise, this is the last review for this piece of code. :) This should cover all cases forever. There's already a unit test for this functionality.
Attachment #8416110 - Flags: review?(alive)
blocking-b2g: 1.4? → 1.4+
Comment on attachment 8416110 [details] [review]
Pull Request - Filter out all titles with 'app://' protocol in them and replace with application name when available (or empty string when not)

startWith seems better
Attachment #8416110 - Flags: review?(alive) → review+
Commit (master): https://github.com/mozilla-b2g/gaia/commit/d33e4f1531a687eed3beb4f34668b126b9d4c5fb

Commit (v1.4): https://github.com/mozilla-b2g/gaia/commit/13835b01a080e16ee3a3ebeda14e7762337fcf69

Even though master was unaffected by this issue we opted to use the same code on master and on v1.4.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
This issue has been fixed on the Buri 1.4 MOZ RIL

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140508000201
Gaia: 4ce973ef0732b0d52cb043210db598aa176b2ce9
Gecko: 16ab7f6b18f8
Version: 30.0
Firmware Version: v1.2-device.cfg
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.