Closed Bug 1004567 Opened 7 years ago Closed 7 years ago

[Camera] Update app to use getter/setter methods for complex parameter types

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mikeh, Assigned: mikeh)

References

Details

Attachments

(1 file, 2 obsolete files)

See CameraControl.webidl changes here:
https://bugzilla.mozilla.org/attachment.cgi?id=8412146&action=diff#a/dom/webidl/CameraControl.webidl_sec2

tl;dr:
.meteringAreas --> get/setMeteringAreas()
.focusAreas --> get/setFocusAreas()
.pictureSize --> get/setPictureSize()
.thumbailSize --> get/setThumbnailSize()

The first two were not used in the Camera app, so they were just removed; the latter two were used so the get/setters were added in parallel with the attributes; once the app has changed over, we can remove the attributes.
Assignee: nobody → mhabicher
Status: NEW → ASSIGNED
Attachment #8432676 - Flags: review?(jdarcangelo)
Comment on attachment 8432676 [details]
Link to PR to remove 'pictureSize' and 'thumbnailSize' from lib/camera.js

Looks good to me!
Attachment #8432676 - Flags: review?(jdarcangelo) → review+
Update the unit test.
Attachment #8432676 - Attachment is obsolete: true
Attachment #8432762 - Flags: review?(jdarcangelo)
Comment on attachment 8432762 [details]
Link to PR to remove 'pictureSize' and 'thumbnailSize' from lib/camera.js, v1.1

Conditional R+ -- see comments in GitHub PR; after making those changes Travis should go green and we can land
Attachment #8432762 - Flags: review?(jdarcangelo) → review+
Update patch per review feedback; carrying r+ forward.

This passes in a local run. Fingers crossed for Travis.
Attachment #8432762 - Attachment is obsolete: true
Attachment #8433426 - Flags: review+
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 931155
You need to log in before you can comment on or make changes to this bug.