Closed Bug 1004864 Opened 6 years ago Closed 5 years ago

Intermittent test_messagemanager_targetchain.html | Test timed out.

Categories

(Firefox OS Graveyard :: General, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox38 wontfix, firefox38.0.5 wontfix, firefox39 fixed, firefox40 fixed, firefox41 fixed, firefox-esr31 unaffected, firefox-esr38 fixed, b2g-v2.0 fixed, b2g-v2.1 fixed, b2g-v2.1S fixed, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S13 (29may)
Tracking Status
firefox38 --- wontfix
firefox38.0.5 --- wontfix
firefox39 --- fixed
firefox40 --- fixed
firefox41 --- fixed
firefox-esr31 --- unaffected
firefox-esr38 --- fixed
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed
b2g-v2.1S --- fixed
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: KWierso, Assigned: kanru)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=38900220&tree=B2g-Inbound
b2g_emulator_vm b2g-inbound debug test mochitest-debug-7 on 2014-05-01 14:36:07 PDT for push 5a44ea372a73

slave: tst-linux64-spot-661



15:37:11     INFO -  615 INFO TEST-START | /tests/dom/base/test/test_messagemanager_targetchain.html
15:37:11     INFO -  [Child 722] WARNING: Transparent content with displayports can be expensive.: file ../../../gecko/layout/base/nsDisplayList.cpp, line 1339
15:37:12     INFO -  [Child 722] WARNING: Transparent content with displayports can be expensive.: file ../../../gecko/layout/base/nsDisplayList.cpp, line 1339
15:37:13     INFO -  [Child 722] WARNING: Transparent content with displayports can be expensive.: file ../../../gecko/layout/base/nsDisplayList.cpp, line 1339
15:37:14     INFO -  [Child 722] WARNING: Transparent content with displayports can be expensive.: file ../../../gecko/layout/base/nsDisplayList.cpp, line 1339
15:37:15     INFO -  [Child 722] WARNING: Transparent content with displayports can be expensive.: file ../../../gecko/layout/base/nsDisplayList.cpp, line 1339
15:37:15     INFO -  [Child 722] WARNING: Transparent content with displayports can be expensive.: file ../../../gecko/layout/base/nsDisplayList.cpp, line 1339
15:37:16     INFO -  [Child 722] WARNING: Transparent content with displayports can be expensive.: file ../../../gecko/layout/base/nsDisplayList.cpp, line 1339
15:42:23     INFO -  616 INFO TEST-UNEXPECTED-FAIL | /tests/dom/base/test/test_messagemanager_targetchain.html | Test timed out.
15:42:24     INFO -  617 INFO TEST-INFO | MEMORY STAT vsize after test: 131743744
15:42:24     INFO -  618 INFO TEST-INFO | MEMORY STAT residentFast after test: 74051584
15:42:25     INFO -  619 INFO TEST-INFO | MEMORY STAT heapAllocated after test: 22996668
15:42:25     INFO -  620 INFO TEST-END | /tests/dom/base/test/test_messagemanager_targetchain.html | finished in 314494ms




15:45:58     INFO -  709 INFO SimpleTest FINISHED
15:45:58     INFO -  [Parent 666] WARNING: NS_ENSURE_TRUE(mCallback) failed: file ../../../../gecko/content/base/src/nsFrameMessageManager.cpp, line 669
15:45:58     INFO -  [Parent 666] WARNING: NS_ENSURE_TRUE(mCallback) failed: file ../../../../gecko/content/base/src/nsFrameMessageManager.cpp, line 669
15:45:58     INFO -  [Parent 666] WARNING: NS_ENSURE_TRUE(mCallback) failed: file ../../../../gecko/content/base/src/nsFrameMessageManager.cpp, line 669
15:45:58     INFO -  [Parent 666] WARNING: NS_ENSURE_TRUE(mCallback) failed: file ../../../../gecko/content/base/src/nsFrameMessageManager.cpp, line 669
15:45:58     INFO -  [Parent 666] WARNING: NS_ENSURE_TRUE(mCallback) failed: file ../../../../gecko/content/base/src/nsFrameMessageManager.cpp, line 669
15:45:58     INFO -  [Parent 666] WARNING: NS_ENSURE_TRUE(mCallback) failed: file ../../../../gecko/content/base/src/nsFrameMessageManager.cpp, line 669
15:46:00     INFO -  [Parent 666] WARNING: An event was posted to a thread that will never run it (rejected): file ../../../gecko/xpcom/threads/nsThread.cpp, line 432
15:46:00     INFO -  [Parent 666] WARNING: unable to post continuation event: file ../../../gecko/xpcom/io/nsStreamUtils.cpp, line 441
15:46:13     INFO -  [Child 722] WARNING: Transparent content with displayports can be expensive.: file ../../../gecko/layout/base/nsDisplayList.cpp, line 1339
15:46:15     INFO -  [Child 722] ###!!! ABORT: constructor for actor failed: file PLayerTransactionChild.cpp, line 134
15:46:15     INFO -  [Child 722] WARNING: content process _exit()ing: file ../../../gecko/dom/ipc/ContentChild.cpp, line 1323
15:46:15     INFO -  Stopping web server
15:47:18     INFO -  Stopping web socket server
15:47:18     INFO -  Stopping ssltunnel
15:47:18     INFO -  Mochitest INFO | runtestsb2g.py | Running tests: end.
15:47:21     INFO - Return code: 0
Kan-Ru, any ideas what might be happening with this test failure?
Flags: needinfo?(kchen)
https://tbpl.mozilla.org/?tree=Try&rev=b3918369d799

Request full log...
Flags: needinfo?(kchen)
(In reply to Kan-Ru Chen [:kanru] from comment #171)
> https://tbpl.mozilla.org/?tree=Try&rev=b3918369d799
> 
> Request full log...

Unable to reproduce this on the try server so I'd like to commit the SimpleTest.requestCompleteLog() to m-c.
Kan-Ru, can you please take a look at this frequent failure? Thanks!
Flags: needinfo?(kchen)