Closed Bug 1005048 Opened 8 years ago Closed 8 years ago

Problem installing app

Categories

(Firefox Graveyard :: Web Apps, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 29

People

(Reporter: marketplace, Assigned: marco)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_2) AppleWebKit/537.75.14 (KHTML, like Gecko) Version/7.0.3 Safari/537.75.14

Steps to reproduce:

I just tested my app “Cube Time & Expense Tracking” published on the Marketplace at:

https://marketplace.firefox.com/app/cube-time-expense-tracking/
Tested on Firefox 29 on OSX 10.9.2, and the following occurs: 


Actual results:

1. When taping the install button, the install progress is displayed but never finishes, restarting firefox and going to the listing shows the app as installed and presents the option to Launch.
2. When tapping the launch button nothing happens. The app does not launch and no other feedback occurs.

Installing other apps works and manually launching the app from Finder also works.


Expected results:

Install should work
Component: General → Web Apps
Product: Marketplace → Firefox
Target Milestone: --- → Firefox 29
Version: 2014-Q2 → unspecified
So, the app is actually installed in the system but you can't launch it from Marketplace, right?
Flags: needinfo?(marketplace)
On OS X I was able to launch it by clicking the app in Finder.

Here's a picture of the never ending Install hanger:

https://www.dropbox.com/s/3zo78iv423t1u29/Screenshot%202014-05-07%2015.44.09.png
The app is installed on the system and can't be launched from the Marketplace.
Launching from Finder displays the "This App is not code signed" dialog but runs if you bypass Gatekeeper.
On firefox the install never completes. If I quit the browser and relaunch it shows as installed but clicking the launch button has no effect.
Flags: needinfo?(marketplace)
(In reply to marketplace from comment #3)
> The app is installed on the system and can't be launched from the
> Marketplace.
> Launching from Finder displays the "This App is not code signed" dialog but
> runs if you bypass Gatekeeper.

This is bug 841929.

> On firefox the install never completes. If I quit the browser and relaunch
> it shows as installed but clicking the launch button has no effect.

I can reproduce this problem. Looks like it only happens with apps using AppCache.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
The problem is that there's an error while downloading the AppCache.

This is a regression from bug 910466.

In the AppCacheObserver code, we should set the |error| property on the Webapps:UpdateState message, and not on the Webapps:FireEvent message.
Assignee: nobody → mar.castelluccio
Status: NEW → ASSIGNED
The other problem (the app isn't launchable) is actually the expected behavior, because the installation is considered still pending (http://hg.mozilla.org/mozilla-central/annotate/3a9f212f6fd9/dom/apps/src/Webapps.jsm#l1240)
Attached patch PatchSplinter Review
Attachment #8420336 - Flags: review?(fabrice)
P.S.: marketplace (I don't know what your real name is :P), you may want to fix your AppCache manifest, that is currently empty (http://www.cubeanywhere.com/cache.appcache).
Attachment #8420336 - Flags: review?(fabrice) → review+
https://hg.mozilla.org/mozilla-central/rev/f6d51fa4f476
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1005052
Actually the app cache manifest was not empty it was returning a 404. The app enables offline mode only if set in the Settings by the user. That's why the app cache manifest was returning a 404. I did fix the web app.manifest to not include the .appcache.
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.