Closed Bug 1005081 Opened 6 years ago Closed 5 years ago

4.9-5.9% tp5o regression for osx 10.6/win7 on aurora (v31) uplift, missing fix from 985017

Categories

(Core :: ImageLib, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: jmaher, Unassigned)

References

Details

(Keywords: perf, regression, Whiteboard: [talos_regression])

On the uplift this week, we have two tp5o regressions reported.  Here is a friendly link to a graph:
http://graphs.mozilla.org/graph.html#tests=[[255,52,21],[255,52,25]]&sel=1396451047316,1399043047317&displayrange=30&datatype=running

This was a confusing bug- we never had a regression for tp5o on inbound (v31), so why did we regress on uplift?  I found out that we had a perf win on Aurora (v30) when bug 985017 landed!  Yay for wins, but we never landed this fix on trunk.

I recommend landing this fix in 31 (current aurora) and 32 (current trunk)
Blocks: 990085
:mwu, is there any chance we could land the perf win from bug 985017 on future branches like fx 32/33? (it is too late for 31)
Flags: needinfo?(mwu)
Bug 985017 only applied to the old thebes based image drawing code. It disappeared when the image drawing code was converted to Moz2D, so there's nothing to land. Also, the optimization only applies when we're using volatile images, which is not the case.
Flags: needinfo?(mwu)
any concerns with closing this as wontfix?
Do we know what specific pages regressed? Or was it across the board?
we have shipped this.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.