Closed Bug 1005105 Opened 6 years ago Closed 5 years ago

Tab background color doesn't match toolbar color in Firefox 29 (need to remove the noise texture)

Categories

(Firefox :: Theme, defect)

29 Branch
x86_64
Windows 7
defect
Not set
Points:
2

Tracking

()

RESOLVED FIXED
Firefox 39
Iteration:
39.2 - 23 Mar
Tracking Status
firefox39 --- fixed

People

(Reporter: vtqobex, Assigned: dao)

References

Details

Attachments

(2 files, 2 obsolete files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140421221237

Steps to reproduce:

Look at the background of the active tab vs. the background of the toolbar.


Actual results:

The background colors don't match. There's a distinct boundary line between the tab and the toolbar. The difference is more noticeable on some displays.


Expected results:

The background colors should be the same.
The color varies pixel to pixel but the tab color hovers around RGB 239/245/251 and the toolbar color is around 231/241/251.
Attached image Tab vs. toolbar (obsolete) —
(1) I actually, honestly, can't see a difference between the tab and the toolbar in your screenshot
(2) This was filed already but I can't find the dupe right now, so marking as DUPEME...

Stephen, can you look into this?
Component: Untriaged → Theme
Flags: needinfo?(shorlander)
Whiteboard: DUPEME
It is slightly off in the screenshot, probably has something to do with the tab stroke overlay. But I am not noticing it locally…
Flags: needinfo?(shorlander)
I can easily see a mismatch in the screenshot and locally if I look at my display from a suboptimal angle.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: firefox-backlog+
Duplicate of this bug: 1009437
Summary: Tab background color doesn't match toolbar color in Firefox 29 → Tab background color doesn't match toolbar color in Firefox 29 (need to remove the noise texture)
Stephen could you please provide the needed images with the noise removed? I believe this is the complete list:

tab-active-middle.png
tab-active-middle@2x.png
tab-background-end.png
tab-background-end@2x.png
tab-background-middle.png
tab-background-middle@2x.png
tab-background-start.png
tab-background-start@2x.png
tab-stroke-end.png
tab-stroke-end@2x.png
tab-stroke-start.png
tab-stroke-start@2x.png

We'll also want to copy the updated images over to browser/themes/linux/tabbrowser/, except for the @2x variants.
Flags: needinfo?(shorlander)
Whiteboard: DUPEME
(In reply to Dão Gottwald [:dao] from comment #7)
> Stephen could you please provide the needed images with the noise removed? I
> believe this is the complete list:

or mmaslaney...
Flags: needinfo?(mmaslaney)
Attached patch remove-tab-noise.patch - 01 (obsolete) — Splinter Review
I exported new images and made sure they do not have any kind of background or noise on them. But I am still getting weird artifacts or dithering on the tabs. Can someone else verify this please?

It might have nothing to do with the images and instead something to do with the way the tabs are constructed?
Flags: needinfo?(shorlander)
Flags: needinfo?(mmaslaney)
Flags: needinfo?(jaws)
Flags: needinfo?(dao)
Comment on attachment 8575986 [details] [diff] [review]
remove-tab-noise.patch - 01

This surely looks like a definite improvement to me. I'll attach a before/after screenshot with a filter applied to make the noise and the lack thereof more visible.
Flags: needinfo?(dao)
Attachment #8575986 - Flags: feedback+
Attached patch patchSplinter Review
Also using the new textures on Linux.
Assignee: nobody → dao
Attachment #8416546 - Attachment is obsolete: true
Attachment #8575986 - Attachment is obsolete: true
Flags: needinfo?(jaws)
Attachment #8576024 - Flags: review?(jaws)
Status: NEW → ASSIGNED
Iteration: --- → 39.2 - 23 Mar
Points: --- → 2
Flags: qe-verify+
Comment on attachment 8576024 [details] [diff] [review]
patch

Review of attachment 8576024 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me
Attachment #8576024 - Flags: review?(jaws) → review+
https://hg.mozilla.org/mozilla-central/rev/9421390046aa
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 39
This looks like a very low visibility/impact UI issue, not really worth the effort for manual testing.
Flags: qe-verify+ → qe-verify-
I was just wondering why was the OS set to windows 7 , where I can see an attachment from linux
(In reply to Towkir Ahmed [:Towkir] from comment #20)
> I was just wondering why was the OS set to windows 7 , where I can see an
> attachment from linux

The screenshots are from Windows, but one has had the contrast modified.
You need to log in before you can comment on or make changes to this bug.