turbo default to off if below a specified amount of RAM

RESOLVED WORKSFORME

Status

--
enhancement
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: dave532, Unassigned)

Tracking

Trunk
x86
Windows 2000
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt3])

(Reporter)

Description

17 years ago
Mozilla uses more RAM than any other single application on my system therefore I
was against enabling turbo mode by default whatsoever, however as it is enabled
now I believe the installer should be intelligent and default on if the amount
of RAM in the system is above a specified amount (e.g. 128MB or above on Windows
9x, I'd suggest making it a little higher for Win2k/XP) and if it's below this
limit default to off.

On my Win2k machine with 128MB memory then I very quickly exceed the amount of
physical RAM and my hard drives effective life will be reduced with all the
swapping, the only reason I have a Win2k system is to test mozilla but I
normally have one or two apps open at the same time too. 
Memory is cheap and I need to get some, that'll fix the problem for me. But what
about the people who don't know how to upgrade their harware or even narrow down
the cause of the problem. There'll always be some people who blindly accept the
installation defaults and if they have 64MB of RAM then they're gonna have a lot
less memory free.

I know a lot of computer illiterate who have their system trays full of these
quick launch icons from the likes of real player, they don't want them there but
dunno how to delete them, on low memory systems it makes things go to a complete
crawl.
(Reporter)

Updated

17 years ago
Blocks: 75599

Comment 1

17 years ago
Even if we have it off by default, we should probably add text discouraging
people from enabling it if they have modest amounts of RAM.

Updated

17 years ago
Target Milestone: --- → M1

Updated

17 years ago
Target Milestone: M1 → Future

Comment 2

17 years ago
Turbo is not enabled by default in Mozilla builds. I suppose this is only a bug
for vendors who do enable it by default. 

Comment 3

17 years ago
Nominating for nsbeta1, since it will be on default for MachV.
Keywords: nsbeta1

Comment 4

17 years ago
not for nsbeta1
Keywords: nsbeta1 → nsbeta1-

Comment 5

17 years ago
renominating for reconsideration, this isn't just an installer issue, cc kmurray
to represent other component needs. QL is one of the top features in the MachV
release, and it isn't clear that we can be successful enabling it on all
machines without considering the available RAM.  CC'ing Blaker, who has bug
98673 on QL memory use, and other engineers cc'd on that bug.  We need to
resolve the memory use issue for the vast majority of users.  What do we need to
do, and who else do we need to get involved?
Blocks: 108795
Keywords: nsbeta1- → nsbeta1

Comment 6

17 years ago
I agree that this would be good behavior, but it seems like this might take a
bit of time to implement. If we can get to a place where we don't introduce any
new UI (aka wording in the QL config dialog), and the installer just knows how
to do the right thing, I'm all for it. We would need to see who's available to
do the work, and I bet it's a doomed engineer. :-)
This may be something we can do after beta... it shouldn't be too hard or risky,
but it is work we don't have time for at the moment.
Summary: Default preloader (turbo mode/quicklaunch) to off in installer if below a specified amount of RAM → turbo default to off if below a specified amount of RAM
Target Milestone: Future → ---
Severity: normal → enhancement
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt3]
Target Milestone: --- → mozilla1.0.1

Updated

17 years ago
No longer blocks: 75599

Updated

17 years ago
Blocks: 75599
Doing this is simple, just use the GlobalMemoryStatus() windows function and put
some arbitrary threshhold in the config.ini -- but what value should we use?
Some amount of physical memory? *free* physical memory? I assume we don't care
how much virtual memory, but we could check that too.

So who's going to pull a number out of their ear?
Assignee: syd → curt

Comment 9

17 years ago
96 MB physical RAM or less triggers warning?  I would hope we don't install at
all unless user has 64 MB.  

Comment 10

17 years ago
Changing nsbeta1+ [adt3] bugs to nsbeta1- on behalf of the adt.  If you have any
questions about this, please email adt@netscape.com.  You can search for
"changing adt3 bugs" to quickly find and delete these bug mails.
Keywords: nsbeta1-

Comment 11

17 years ago
Changing nsbeta1+ [adt3] bugs to nsbeta1- on behalf of the adt.  If you have any
questions about this, please email adt@netscape.com.  You can search for
"changing adt3 bugs" to quickly find and delete these bug mails.
Keywords: nsbeta1+

Comment 12

15 years ago
retargeting
Target Milestone: mozilla1.0.1 → Future
Product: Browser → Seamonkey

Updated

13 years ago
QA Contact: bugzilla → general

Comment 13

13 years ago
if default is already OFF, then isn't this bug invalid?
Assignee: curt → nobody
Target Milestone: Future → ---
Turbo is off by default
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.