Closed Bug 1005391 Opened 8 years ago Closed 8 years ago

[B2G][Tarako][Camera]Taking a picture or video as a call comes in causes the device to become unresponsive

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

(blocking-b2g:1.3T+, b2g-v1.3 unaffected, b2g-v1.3T affected)

RESOLVED DUPLICATE of bug 974127
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected

People

(Reporter: JMercado, Unassigned)

References

Details

(Keywords: hang, Whiteboard: [tarako-exploratory])

Attachments

(2 files)

Description:
If the user takes a picture or starts recording a video as the first ring of an incoming call is heard, the device will become unresponsive.  No buttons will work, including the power button, and the user must remove the battery to continue use.  The camera will continue recording after this bug happens.

Repro Steps:
1) Update a Tarako to BuildID: 20140502014001
2) Open the camera and be ready to take a picture
3) Have another device call the phone
4) As soon as the first ring is heard take a picture (press multiple times for best repro)

Actual:
The phone becomes unresponsive.

Expected:
The incomming call can be answered and the phone can continue to be used.

1.3T Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140502014001
Gaia: a8e0ff550de08e58e4bf75af3cecf175b9b71e70
Gecko: 71790bf476cb
Version: 28.1
Firmware Version: sp6821a-Gonk-4.0-4-29

Notes:  Timing is key for this issue.  Pressing the shutter button too early or too late will not reproduce this bug.


Repro frequency: 80%
See attached: logcat, firewatch report, video
This issue does not occur on 1.3 Buri.

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140501024001
Gaia: 667539f1ed4becc45b182a5f1046221d3eeb9e7c
Gecko: 4b68615ea3e5
Version: 28.0
Firmware Version: v1.2-device.cfg

The user can continue to use the phone normally after taking a picture right as a call comes in.
blocking-b2g: --- → 1.3T?
Ni? Etienne
given that Bug 990003 has already landed, i wonder if there is anything that can possibly be done? Thanks
Flags: needinfo?(etienne)
Severity: normal → critical
Keywords: hang
(In reply to Joe Cheng [:jcheng] from comment #4)
> Ni? Etienne
> given that Bug 990003 has already landed, i wonder if there is anything that
> can possibly be done? Thanks

Sadly I'm completely out of gaia-level suggestion for this.
Maybe Gabriele could give some lower-level ideas?
Flags: needinfo?(etienne) → needinfo?(gsvelto)
blocking-b2g: 1.3T? → 1.3T+
basic user scenario leading to unresponsive phone - hence blocking it
ni? Thinker to see if your team can look into this as well. thanks
Flags: needinfo?(tlee)
patrick would look into.
Flags: needinfo?(tlee)
B2G process is in a loop in nsContentUtils::IsUserFocusIgnored() in nsContentUtils.cpp. The while loop use aNode as condition, but aNode->OwnerDoc()->GetWindow() returns null, aNode will never update and the loop won't break.
Flags: needinfo?(bugs)
Yup, IIRC there is even a bug open for that case. Want to fix?
Flags: needinfo?(bugs)
Er, wait, isn't that fixed already.
Which branch are you looking at.
(In reply to Olli Pettay [:smaug] from comment #11)
> Er, wait, isn't that fixed already.
> Which branch are you looking at.

1.3t.
So we need to take this patch on 1.3t.
I don't know which gecko branch 1.3t is, so want to ask approval for the patch for Bug 974127?
Can we land bug 974127 on v1.3t?
Flags: needinfo?(fabrice)
Just ask approval for the patch in that bug.
Nominated bug 974127 for 1.3t?
Depends on: 974127
Flags: needinfo?(fabrice)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 294127
Duplicate of bug: 974127
Flags: needinfo?(gsvelto)
You need to log in before you can comment on or make changes to this bug.