Attempting to print crashes the browser.

VERIFIED WORKSFORME

Status

()

Core
Printing: Output
--
critical
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Charles Hixson, Assigned: dcone (gone))

Tracking

({crash})

Trunk
x86
Windows 95
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

635.94 KB, application/octet-stream
Details
(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091303

Attempting to print page http://www.linuxprinting.org/suggested.html crashes the
browser.  Copying it to word, and printing from there works without hitch.

Reproducible: Always
Steps to Reproduce:
1. (optionally) Reboot
2. go to http://www.linuxprinting.org/suggested.html
3. click on the printer icon (I didn't try from the menu).

Actual Results:  Application has performed an illegal operation.

Netscape network printer.  HP 5 SI, double sided printing on letter size paper.

Comment 1

17 years ago
I tryed it from menu and via printer icon and it prints page okay without problem.

WinNT4 + 2001091803
(Reporter)

Comment 2

17 years ago
Sorry, that should have been Novell Network printer.

Updated

17 years ago
Severity: normal → critical
Keywords: crash

Comment 3

17 years ago
worksforme on win98 using 9/25 branch build..

please try again on more recent build.
(Reporter)

Comment 4

17 years ago
Using build 2001092603 http://www.linuxprinting.org/suggested.html still crashes
when I attempt to print.  I am using Win95 4.00.950 B.  And printing to a Novell
Network printer:  HP5si

Comment 5

17 years ago
If you are crashing in Mozilla the best thing you can do to help the developers
fix your bug is to attach a stacktrace. If you're not building yourself you are
not out of luck.  Mozilla (thanks to a very cool donation from Netscape)
releases nightly and milestone builds with Full Circle's Talkback. Talkback
should catch most crashes and offer to send in a crash report. I can retrieve
that crash report and attach it to your bug report if you provide either the
Incident ID (you can get it by running the talkback program from
/components/talkback/) or you can let me know the email address you used to
submit the report and the time of sending. Thanks for your help in testing
Mozilla and reporting bugs.
Charles: To elaborate on Asa's comment, you can get a talkback-enabled build here:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-talkback.zip
(as always, be sure to delete your old Mozilla directory before installing the
new one)

You may also wish to try a fresh profile. You can manage/create profiles with
"mozilla.exe -profilemanager".
(Reporter)

Comment 7

17 years ago
I *HAVE* a talkback version of the program.  But it doesn't produce a talkback dump, it just crashes.  "This program has performed an illegal operation".  For many other errors I have generated and submitted talkback dumps.  For this one not talkback dump is produced.
Reporter: Does a fresh profile alleviate your problem?

Comment 9

17 years ago
I saw this bug under Windows 98 with build 2001091403 and URL:
http://www.nfb.ca/danseduguerrier/
The same URL printed fine on another system under NT and Netscape 4.7 (I think)

I have not tried the remedies suggested below (new version of Mozilla, new profile)

Got the bug once, didn't try again.

I will post a DrWatson dump. No talkback sent, although my version is enabled
(and has sent other talkbacks).

DrWatson Diagnosis tab reads:
---cut here----
PostScript Printer Driver used an uninitialized variable, attempted to access
memory or a DLL that has been freed, or encountered some other nonspecific error.

Module Name: PSCRIPT.drv
Description: PostScript Printer Driver
Version: 4.10.1998
Product: Microsoft(R) Windows(R) Operating System
Manufacturer: Microsoft Corporation

Application Name: Mozilla.exe
---cut here----

Comment 10

17 years ago
Created attachment 51900 [details]
DrWatson file showing crash

Comment 11

17 years ago
The printer is a network-connected HP 4050.
Peter: Unfortunatly, Dr Watson dumps are not actually very helpful :-(. And, as
your build is not triggering talkback, I would be inclined to think that this
may be a printer problem, as opposed to a Mozilla problem.

After trying a more recent build, and a new profile, you may also want to try
loading the very latest drivers for your printer.

Comment 13

17 years ago
Printing the URL http://www.nfb.ca/danseduguerrier/ on networked HP4050 worked
fine with Build ID 2001100403.
Charles: Has a recent build solved your issue as well?

Comment 15

17 years ago
No Activity in a month, suspected non-Moz bug, and one of the 2 who saw this
solved it with a driver update, marking WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 16

17 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.