APPLICATION_REPUTATION_COUNT histogram is busted

RESOLVED FIXED in Firefox 30

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mmc, Assigned: mmc)

Tracking

unspecified
mozilla32
x86
macOS
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox30 fixed, firefox31 fixed, firefox32 fixed, b2g-v1.4 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

I filed bug 983494 a while back but we may as well fix it on our side. We get sensible histograms with kind: boolean and garbage with kind: flag, though they should be synonyms.
Assignee: nobody → mmc
Status: NEW → ASSIGNED
Attachment #8416923 - Flags: review?(gpascutto)
Comment on attachment 8416923 [details] [diff] [review]
Fix telemetry for application reputation (

Review of attachment 8416923 [details] [diff] [review]:
-----------------------------------------------------------------

Do I read it correctly and does this require that your tests are run in a specific order? It may be easier to read/modify if you can reset the telemetry in-between.
Attachment #8416923 - Flags: review?(gpascutto) → review+
(In reply to Gian-Carlo Pascutto [:gcp] from comment #2)
> Comment on attachment 8416923 [details] [diff] [review]
> Fix telemetry for application reputation (
> 
> Review of attachment 8416923 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Do I read it correctly and does this require that your tests are run in a
> specific order? It may be easier to read/modify if you can reset the
> telemetry in-between.

Thanks -- I don't think I can reset the telemetry, but I can read it. Let me try that. This test is timing out on windows, too.

https://tbpl.mozilla.org/?tree=Try&rev=f1aa500cbbf0
Attachment #8416923 - Attachment is obsolete: true
Comment on attachment 8417549 [details] [diff] [review]
Fix telemetry for application reputation (

Review of attachment 8417549 [details] [diff] [review]:
-----------------------------------------------------------------

Is this better? I decided to abort the windows test changes, there's some async stuff going on there that unfortunately I don't have to look into this week.
Attachment #8417549 - Flags: review?(gpascutto)
Comment on attachment 8417549 [details] [diff] [review]
Fix telemetry for application reputation (

Review of attachment 8417549 [details] [diff] [review]:
-----------------------------------------------------------------

I like this more than the arbitrary incrementing number sets, yes :)
Attachment #8417549 - Flags: review?(gpascutto) → review+
https://hg.mozilla.org/mozilla-central/rev/12df2fde3a57
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
Comment on attachment 8417549 [details] [diff] [review]
Fix telemetry for application reputation (

[Approval Request Comment]
Bug caused by (feature/regressing bug #): telemetry bug 983494
User impact if declined: none, developer impact is that we can't tell how a feature is doing
Testing completed (on m-c, etc.): added unittest
Risk to taking this patch (and alternatives if risky): very low, telemetry only
String or IDL/UUID changes made by this patch: none
Attachment #8417549 - Flags: approval-mozilla-beta?
Attachment #8417549 - Flags: approval-mozilla-aurora?
Attachment #8417549 - Flags: approval-mozilla-beta?
Attachment #8417549 - Flags: approval-mozilla-beta+
Attachment #8417549 - Flags: approval-mozilla-aurora?
Attachment #8417549 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.